Please login or register.

Login with username, password and session length
Advanced search  

News:

Forum rules - please read before posting, it can save you a lot of time.

Author Topic: "White chamber" source. Missing sprites  (Read 3480 times)

0 Members and 1 Guest are viewing this topic.

Borbel

  • Lurker
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 42
    • View Profile
"White chamber" source. Missing sprites
« on: February 22, 2014, 09:39:14 AM »

Hello guys, I hope some of you tested “white chamber” sources. If so, could somebody explain me how to solve missing sprites problem in “scene editor”.

I have many “Invalid image” – signs, but there are no sprites at all, when I try to explore any scene in “scene editor”.
Logged

3cats

  • Lurker
  • *
  • Karma: 1
  • Offline Offline
  • Posts: 18
    • View Profile
Re: "White chamber" source. Missing sprites
« Reply #1 on: February 22, 2014, 06:38:27 PM »

Can you tell us where we can find the sources ?
Logged

Borbel

  • Lurker
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 42
    • View Profile
Re: "White chamber" source. Missing sprites
« Reply #2 on: February 22, 2014, 08:25:57 PM »

Logged

3cats

  • Lurker
  • *
  • Karma: 1
  • Offline Offline
  • Posts: 18
    • View Profile
Re: "White chamber" source. Missing sprites
« Reply #3 on: February 23, 2014, 06:13:54 AM »

Thank you for making your source files available to us. It's nice to be able to learn from other people's projects!

As for your question about the scene editor : I have only been using WME for a  few weeks, but one thing that comes to mind is : have you been changing your directory structure at all ? I mean, moving folders around and such ?
Once I point to the image/sprite again in the editor, it doesn't disappear on closing & reopening the editor... So, all seems to be fine... ???

Logged

Borbel

  • Lurker
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 42
    • View Profile
Re: "White chamber" source. Missing sprites
« Reply #4 on: February 23, 2014, 11:46:30 AM »

Thank you for making your source files available to us. It's nice to be able to learn from other people's projects!
These sources aren't mine actually. The project is property of "studiotrophis".

Quote
As for your question about the scene editor : I have only been using WME for a  few weeks, but one thing that comes to mind is : have you been changing your directory structure at all ? I mean, moving folders around and such ?
Once I point to the image/sprite again in the editor, it doesn't disappear on closing & reopening the editor... So, all seems to be fine... ???
Hmm ok, i'll check that, by the way, what do you exactly mean by pointing to the image/sprite, cause there are no paths to the sprites at all there,  invalid_debug.bmp - that's all that I can see when I try to change the path to any sprite in the editor.
Logged

3cats

  • Lurker
  • *
  • Karma: 1
  • Offline Offline
  • Posts: 18
    • View Profile
Re: "White chamber" source. Missing sprites
« Reply #5 on: February 23, 2014, 12:43:03 PM »

In the scene editor, first select the correct layer by clicking on it (eg. for scene 'blackchamber' : select 'main'). Then select the node that you want (eg. 'background'). Then go to 'entity properties' : 'sprite'. On the right side of the input box, there are 3 dots. Click on that button and navigate to the correct image location (eg. 'scenes\BlackChamber\Artwork\BackgroundBlackChamber.png'). The image should now show up in the editor. Save.
Et voila!
 :)
Logged

Borbel

  • Lurker
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 42
    • View Profile
Re: "White chamber" source. Missing sprites
« Reply #6 on: February 23, 2014, 01:14:04 PM »

I see, thanks for detailed response 3cats, but unfortunately, such solution won't be good for me. Reopening every sprite in every scene... That's exactly what I didn't want. Perhaps there are more elegant ways to solve the problem?
Logged

piere

  • Supporter
  • Frequent poster
  • *
  • Karma: 4
  • Offline Offline
  • Posts: 301
  • Sorry for any bad english in my posts. Game on !
    • View Profile
Re: "White chamber" source. Missing sprites
« Reply #7 on: February 23, 2014, 11:05:22 PM »

Dude you have a complete open source game, you are lucky enough to get that. Be grateful and stop complaining about missing sprites.
Logged
 

Page created in 0.159 seconds with 17 queries.