Please login or register.

Login with username, password and session length
Advanced search  

News:

IRC channel - server: waelisch.de  channel: #wme (read more)

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - anarchist

Pages: [1] 2
1
Hello everyone,

We are proud to announce that our point n click mystery adventure game Dr Doyle & The Mystery Of The Cloche Hat has been released on Steam!

http://store.steampowered.com/app/574420/Dr_Doyle__The_Mystery_Of_The_Cloche_Hat/

About the game
An unexplained break-in in the small hamlet of Prescott Lane draws the attention of Dr. Doyle, a man of questionable morality and unreserved inquisitiveness, who realises from the first that things aren't exactly how they seem.

After the body of an ex-convict is found beaten to death in a dark alley, it is up to the Doctor to put the pieces together.

Armed with his straps and his wits, the good Doctor sets out to find the truth and solve the mystery of the cloche hat.
Features
Investigate 1920s Dover, England (with over 80 interactive hotspots)

Gather Clues and Combine them with the Environment and the Characters you Meet

Choose your Method in your Encounters

Make Assumptions, Reach Conclusions and Decide the Guilty Party


2
Technical forum / Moving animation in Window Entity Container does not move
« on: November 27, 2016, 10:48:01 PM »
Hello everyone.

I have created an entity container inside a window. I have linked an entity which has a moving sprite (it is a tiny actor moving left and right).

The entity's animation plays but it does not move left and right. The actor moves his legs and turns left and right but does not move on the screen.

Am I doing something wrong or is there nothing I can do about this?

3
Technical forum / TalkAsync sound file does not work in compiled packages
« on: September 04, 2016, 02:04:02 PM »
Hello everyone,

I use the command:

Code: WME Script
  1. actor.TalkAsync("", "fileName.ogg", 5000);
  2.  

to trigger the talk animation and play a speech sound. I show the dialogue text in a separate window, which is why I send an empty string.

When I run the game in debug mode, the speech sound plays fine. When I compile the game and run it from "packages" folder, the speech sound is not heard. I believe it is not an issue with sound effects volume, because other sound effects are heard fine.

Any ideas why this might happen?

4
Bug reports / SceneEdit crash
« on: May 21, 2016, 05:28:04 PM »
This problem started lately. I recently updated my gpu drivers to latest version.

When I open SceneEdit, the SceneEdit window appears fine and I can click around and do some work. But after some seconds, the window crashes. I have tried installing v1.10 but the problem persists.

Windows event log:
Code: [Select]
Log Name:      Application
Source:        Application Error
Date:          2016-05-21 19:06:01
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      CA-PC
Description:
Faulting application name: SceneEdit.exe, version: 1.10.1.0, time stamp: 0x50081787
Faulting module name: COMCTL32.dll, version: 5.82.9600.17810, time stamp: 0x553afcee
Exception code: 0xc0000005
Fault offset: 0x0002d160
Faulting process id: 0xd14
Faulting application start time: 0x01d1b37aa8e6741d
Faulting application path: C:\Program Files (x86)\WME DevKit\SceneEdit.exe
Faulting module path: C:\Windows\WinSxS\x86_microsoft.windows.common-controls_6595b64144ccf1df_5.82.9600.17810_none_7c5b6194aa0716f1\COMCTL32.dll
Report Id: e8f8a603-1f6d-11e6-85b5-1c6f652d7aea
Faulting package full name:
Faulting package-relative application ID:
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2016-05-21T16:06:01.000000000Z" />
    <EventRecordID>106675</EventRecordID>
    <Channel>Application</Channel>
    <Computer>CA-PC</Computer>
    <Security />
  </System>
  <EventData>
    <Data>SceneEdit.exe</Data>
    <Data>1.10.1.0</Data>
    <Data>50081787</Data>
    <Data>COMCTL32.dll</Data>
    <Data>5.82.9600.17810</Data>
    <Data>553afcee</Data>
    <Data>c0000005</Data>
    <Data>0002d160</Data>
    <Data>d14</Data>
    <Data>01d1b37aa8e6741d</Data>
    <Data>C:\Program Files (x86)\WME DevKit\SceneEdit.exe</Data>
    <Data>C:\Windows\WinSxS\x86_microsoft.windows.common-controls_6595b64144ccf1df_5.82.9600.17810_none_7c5b6194aa0716f1\COMCTL32.dll</Data>
    <Data>e8f8a603-1f6d-11e6-85b5-1c6f652d7aea</Data>
    <Data>
    </Data>
    <Data>
    </Data>
  </EventData>
</Event>

The log from SceneEdit does not appear to have recorded the error:
Code: [Select]
19:05: ********** DEBUG LOG OPENED 21-05-2016 (Release Build) *****************
19:05: Wintermute Engine ver 1.10.1beta, Compiled on Jul 19 2012, 16:18:06
19:05: Platform: Windows XP or higher  (Build 9200)
19:05: DirectX version: 9.0
19:05:
19:05: Scanning packages...
19:05:   Registered 0 files in 0 package(s)
19:05: Initializing scripting engine...
19:05:   Script compiler bound successfuly
19:05: Loading plugins...
19:05:   wme_sample_pixel.dll
19:05:   wme_snow.dll
19:05: Scanning packages...
19:05:   Registered 0 files in 0 package(s)
19:05: Enumerating Direct3D devices...
19:05: Enumerating DirectSound devices...
19:05: Game aspect ratio:    -1.#IND00
19:05: Monitor aspect ratio: 1.777778
19:05: Game aspect ratio is the same as monitor aspect ratio.
19:05: Backup resolution:  0 x 0
19:05:
19:05: Available video devices:
19:05:   AMD Radeon HD 5800 Series (accelerated)
19:05:     Driver: aticfx32.dll 8.17.10.1404
19:05:     Monitor: 0
19:05: Available audio devices:
19:05:   Primary Sound Driver
19:05:   Speakers (Realtek High Definition Audio)
19:05:   Realtek Digital Output(RCA) (Realtek High Definition Audio)
19:05:   Realtek Digital Output (Realtek High Definition Audio)
19:05:   /syseng0019/[no sound]
19:05: Auto selecting devices for windowed mode:
19:05:   Video: AMD Radeon HD 5800 Series (accelerated)
19:05:          Windowed:yes  Colors:16bit  T&L:no  Multisample:0
19:05:   Audio: Primary Sound Driver
19:05: Maximum texture size: 16384x16384
19:05: ----- Open file: 'F:\Job\Games\DrDoyle\scenes\scenes\WhitehavenHallExterior\WhitehavenHallExterior.scene' -----

5
Technical forum / Highilighting a scene Region Entity
« on: April 22, 2016, 11:18:56 PM »
Hello everyone

In my scenes I have mainly region entities. I am trying on MouseEntry to achieve:

- either highlight around the region entity
or
- shade the inside of the region

For instance, in my background I have a bookcase. I traced a region entity around it. Now I would like when the mouse hovers above the bookcase to have a highlighting effect.

I have tried:

Code: WME Script
  1. on "MouseEntry"
  2. {
  3.         this.AlphaColor = 255;
  4. }
  5.  
  6. on "MouseLeave"
  7. {
  8.         this.AlphaColor = 0;
  9. }
  10.  

But this doesn't have any effect.

Any ideas?

6
Hello everyone. I have a very weird issue I cannot solve.

I have only left and right animations for my main actor. No up, down or diagonal animations exist. I simply use the left and right animations everywhere:

Code: WME Script
  1. ; $EDITOR_PROJECT_ROOT_DIR$ ..\..\..\
  2.  
  3. ACTOR
  4. {
  5.         NAME = "MainActor"
  6.         CAPTION=""
  7.         SCALABLE = TRUE
  8.         INTERACTIVE = FALSE
  9.         X = 400
  10.         Y = 460
  11.         SCRIPT="actors\MainActor\MainActor.script"
  12.  
  13.         FONT = "fonts\outline_red.font"
  14.  
  15.         ANIMATION
  16.         {
  17.                 NAME       = "idle"
  18.  
  19.                 LEFT       = "actors\MainActor\left\idle.sprite"
  20.                 RIGHT      = "actors\MainActor\right\idle.sprite"
  21.                 UP         = "actors\MainActor\right\idle.sprite"
  22.                 DOWN       = "actors\MainActor\right\idle.sprite"
  23.  
  24.                 UP_LEFT    = "actors\MainActor\left\idle.sprite"
  25.                 UP_RIGHT   = "actors\MainActor\right\idle.sprite"
  26.                 DOWN_LEFT  = "actors\MainActor\left\idle.sprite"
  27.                 DOWN_RIGHT = "actors\MainActor\right\idle.sprite"
  28.         }
  29.  
  30.         ANIMATION
  31.         {
  32.                 NAME       = "walk"
  33.  
  34.                 LEFT       = "actors\MainActor\left\walk.sprite"
  35.                 RIGHT      = "actors\MainActor\right\walk.sprite"
  36.                 UP         = "actors\MainActor\right\walk.sprite"
  37.                 DOWN       = "actors\MainActor\right\walk.sprite"
  38.  
  39.                 UP_LEFT    = "actors\MainActor\left\walk.sprite"
  40.                 UP_RIGHT   = "actors\MainActor\right\walk.sprite"
  41.                 DOWN_LEFT  = "actors\MainActor\left\walk.sprite"
  42.                 DOWN_RIGHT = "actors\MainActor\right\walk.sprite"
  43.         }
  44.  
  45.         ANIMATION
  46.         {
  47.                 NAME       = "talk"
  48.  
  49.                 LEFT       = "actors\MainActor\left\talk.sprite"
  50.                 RIGHT      = "actors\MainActor\right\talk.sprite"
  51.                 UP         = "actors\MainActor\right\talk.sprite"
  52.                 DOWN       = "actors\MainActor\right\talk.sprite"
  53.  
  54.                 UP_LEFT    = "actors\MainActor\left\talk.sprite"
  55.                 UP_RIGHT   = "actors\MainActor\right\talk.sprite"
  56.                 DOWN_LEFT  = "actors\MainActor\left\talk.sprite"
  57.                 DOWN_RIGHT = "actors\MainActor\right\talk.sprite"
  58.         }
  59. }
  60.  

I display the dialogue in comic book bubbles above the actors. I don't use actor.Talk(), instead I have my own mechanism that prints the text in a static control inside the bubble. But, I use actor.TalkAsync("", null, 10000) to trigger the talk animations of each actor.

My issue is that, sometimes my main actor uses the opposite direction animation. When I click on another actor, he walks toward the point I want him to stand, turns to the other actor (I explicitly call MainActor.TurnTo(direction)). e.g. He has direction 2 (DI_RIGHT) but, while TalkAsync is running, he turns left (i.e. the "left" talk animation is played). Game.Msg(MainActor.Direction) displays 2 which is the correct direction.

This does not always happens. One functionality of my game is that when user clicks on the exit, he immediately exits without walking. So, if I am at a scene and talking to another actor and I am turned left while talking, then I click on exit, go to another scene (through the map), and talk to another actor, this issue occurs. When I click somewhere to walk around and then go back and talk to the other actor, the issue vanishes, but not always!

Is there something I don't understand about TalkAsync or actor directions?

7
I have a static control that must remain at the preset size. The font I have chosen does not have characters of a standard size e.g. character "1" is much smaller than "0".

I have a large text which I am dividing into chunks which I show on the static control. When user clicks, the next chunk is shown.

My problem is that, because of my font, I can't divide the dialogue into chunks of a particular size. I need some way to check whether the text I set to the static control can fit inside it. There must be some way to know this, since we have access to methods like SizeToFit and HeightToFit.

Is there a way to achieve this?

8
I have several inventory items for which I have created cursor sprites. When I select an inventory item I want to hide the main cursor and only show the item cursor. Some item cursors are smaller than the main cursor which results in both cursors being visible.

I have tried adding the following code in game.script:

Code: WME Script
  1. // clicking an inventory item
  2. else if(ActObj.Type == "item" && Item == null)
  3. {
  4.         Game.SelectedItem = ActObj;
  5.         Game.RemoveCursor();
  6. }
  7.  

This removes the main cursor when the mouse is not over a scene entity or actor. But when the cursor hovers over a scene entity or actor, the entity specific cursor appears together with the item's cursor.

A solution would be to make all item cursor sprites larger than the scene entity cursor sprites. But I wonder if there is an easy way through script.

9
Technical forum / How to place an inventory item first
« on: January 19, 2014, 04:04:09 PM »
Hello everyone,

I think the functionality I want is not supported. I would like to have every new item I take using Game.TakeItem to be inserted first. The only thing that is supported is InsertAfter argument which allows you to define after which item to insert the newly taken item. I have tried sending null and "" (empty string) to it but Game.TakeItem always inserts the new item last.

 Is there a work around? Perhaps I can somehow get the inventory array and handle this myself? Any help would be appreciated.

10
Technical forum / ParentNotify not working for sub-window
« on: January 12, 2014, 05:55:14 PM »
Hello all,

Not certain whether this is expected behaviour or if I am doing something wrong. I have a window which contains a nested window. The nested window contains a button named "btnOption1". Both the button and the nested window have ParentNotify = true.

Indide the parent window's script I have added:

Code: WME Script
  1. on "btnOption1"
  2. {
  3.         //do something
  4. }
  5.  

I am expecting this to be called when I press the button inside the nested window. Unfortunately, this is not the case. I set a breakpoint here (I have some code, not comments) and it is never reached.

I have moved the button inside the parent window and the above code is reached. Therefore, something is wrong with the nested window. Do I need to add a script to catch the button press event?

I am working with WME Project Manager 1.10.001 which is still in beta, so I am not sure if this is a bug.

11
Technical forum / Brighten part of the scene
« on: February 23, 2013, 05:04:50 PM »
Hello everybody

I plan to have a scene which will be completely dark when the character enters. Then, when the character finds a pack of matches and lights one, I wish to have an effect where a circle area around the character is brighter than the completely dark scene. The character will be able to walk around the scene therefore brightening parts of the scene. The match effect will stop after a few seconds when the match goes out.

I assume that this is not a trivial requirement. Has someone tried this before, is there a workaround? My game is full 2D.

Thank you

12
Technical forum / Multiline text box
« on: July 13, 2012, 04:55:41 PM »
Hello everyone,

This surely must have been discussed before but I am unable to find a topic in the forum  :-[

I will have a notebook in my game which among other things will have a place for the user to write whatever they want and keep the text saved for the duration of the game. Obviously I will need multiline input as a single line text box is out of the question.

Are there any properties I need to set to the text box so that it becomes multiline or do I need a complex workaround?

Thank you

13
Technical forum / Help with tiled images
« on: May 19, 2012, 11:37:30 PM »
Hello everyone,

I have just started working with tiled images in a window and have met some trouble.

I have a window of dimensions 150x150 which contains a static control of the exact same dimensions. I have created a .image file and have assigned it as the TiledImage of the static control (I have also tried assigning it to the window after I met trouble). The .image file looks like the following:

Code: WME Script
  1. TILED_IMAGE
  2. {
  3.   IMAGE="interface\window\windowBackground.png"
  4.   VERTICAL_TILES { 50, 50, 50 }
  5.   HORIZONTAL_TILES { 50, 50, 50 }
  6. }
  7.  

windowBackground.png is an image of dimensions 150x150 filled with a monochrome colour.

I want this to appear next to the actor and be filled with text. I want it to have fixed length and variable height to adjust to the amount of text. The code I use to show this window is the following (by calling Object.comment(text)).

Code: WME Script
  1. var textBox = commentWindow.GetControl("commentText");
  2.  
  3. method initialize(){
  4.         var height;
  5.         var width;
  6.        
  7.         //place the window
  8.         commentWindow.Height = textBox.Height;
  9.        
  10.         if(actor.X + commentWindow.Width + 10 > Game.ScreenWidth) commentWindow.X = Game.ScreenWidth - width;
  11.         else commentWindow.X = actor.X + 10;
  12.        
  13.         if(actor.Y + commentWindow.Height > Game.ScreenHeight) commentWindow.Y = Game.ScreenHeight - height;
  14.         else commentWindow.Y = actor.Y - actor.Height;
  15. }
  16.  
  17. ////////////////////////////////////////////////////////////////////////////////
  18. method comment(commentText)
  19. {
  20.         textBox.Text = commentText;
  21.         textBox.HeightToFit();
  22.        
  23.         this.initialize();
  24.         this.Visible = true;
  25. }
  26.  

The window successfully adjusts its height on the amount of text the static control contains. Unfortunately, the tiled image seems to not behave correctly. Sometimes it fills the window correctly but sometimes it is cut short at the bottom:



What causes such behaviour? Am I missing something regarding tiled images?

Thank you

14
Technical forum / 2.5D with hand drawn background and 3D actor
« on: October 28, 2011, 10:51:12 AM »
Hello everybody,

We have several hand drawn backgrounds as .png scanned images. We want to use 3D actors (created in 3DS Max).

I guess this is more a graphics question rather than a scripting/programming question. I know that we need a scene geometry for every background/scene. What I am wondering is whether there is a practical and accurate way to create the geometry using the hand drawn backgrounds as templates.

Perhaps someone has followed this method before? It seems to me as a practical way to go, since using hand drawn backgrounds instead of creating whole scenes in 3D and then exporting them sounds less time consuming.

Thanks in advance.

15
Technical forum / The good old .3ds problem
« on: June 06, 2011, 07:56:02 PM »
Hello fellow Muties,

We are having trouble with exporting .3ds files.

We have a scene in 3ds max(it is the original complete scene not a "naked" one). We export it to .3ds and then import it in wintermute. When I select the scene in SceneEdit the camera is available in the drop down (as Camera01). But, when I click on "Display scene geometry" I can see absolutely no change. The hidden geometry does not appear. Neither does the actor appear when I run the game. When I use actor.Talk() I can see the caption somewhere on the left of the screen.

The .3ds file is here http://www.mediafire.com/?nnlm1ubc25r2r5s

Thanks for any help given.


Pages: [1] 2

Page created in 0.414 seconds with 15 queries.