Please login or register.

Login with username, password and session length
Advanced search  


For WME related articles and tutorials visit WME Resource Center.

Author Topic: Little Bug in SceneEdit  (Read 2546 times)

0 Members and 1 Guest are viewing this topic.


  • Wanderer zwischen den Welten
  • Global Moderator
  • Regular poster
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 223
  • There is no spoon. The enemy gate is down!
    • View Profile
Little Bug in SceneEdit
« on: September 30, 2007, 04:43:05 AM »


we found a strange "mini-bug" in the path name handling in sceneedit. We discovered it in Jynx Package Demo Project recently.

Given this directory structure:


data contains the usual stuff, LocationPak and Data are the same level.
LocationPak ist promoted to a package.
All Paths in NextLocation.scene are set like "LocationPak/NextLocation/background.bmp"

You cannot fix this in sceneedit. When reselecting the background.bmp, it doesn't recognize the package and leaves the "LocationPak", which IS part of the path, still in.

The game runs happily in the Project Manager, but the compiled game does not show the background.bmp. It does show the scene, so if you manage to click right, you can get back out of the scene again.

Fixing the path names in NextLocation.scene by hand in a text editor restores the usual behaviour, that is: after doing this, projectman recognizes the new paths as right and does not add the LocationPak again.

I think this may be because if you do not change the filename, SceneEdit does nothing to the stored filename ... for special cases like this, the path should maybe always checked for packages and cut accordingly.
... delete the inner sleep ...


  • WME developer
  • Administrator
  • Addicted to WME forum
  • *
  • Karma: 41
  • Offline Offline
  • Gender: Male
  • Posts: 5674
    • View Profile
    • Dead:Code Site
Re: Little Bug in SceneEdit
« Reply #1 on: September 30, 2007, 08:52:06 AM »

Ok, fixed. It was actually a bug in ProjectMan. It didn't refresh everything it should upon adding a new package, so the paths were generated wrong when adding a new file from template.
Yes, I do have a twitter account
Please don't send me technical questions in private messages, use the forum. ::wave

Page created in 0.312 seconds with 18 queries.