Wintermute Engine Forum

Wintermute Engine => Scripts, plugins, utilities, goodies => Topic started by: raychaser on October 23, 2007, 05:53:52 AM

Title: Blender Export Script...
Post by: raychaser on October 23, 2007, 05:53:52 AM not ready yet  >:D ... Sorry

Hi folks. I spent all week poking at the blender .x export script. I would be so happy to be the hero and deliver a fully working product to this communty. If only I had another week I know I could crack this, but sadly I've run out of time and I need to get going with my actual project now.

Download the script here:

It will look like "DirectXM1 (.x)" in the export menu of blender when you unzip this file and drop it into the scripts directory

It does work (kind of) but it will mean two or three extra steps in fragmotion before it works in WME. Why is this good? Well, it means that I can do all the modeling, rigging and animating in blender and only do simple cleanup steps in fragmotion. This is a step in the right direction I think.

Here's what I fixed:
Problems still:

Now I'm exhausted and on a purely selfish note I have enough to continue my work in blender using fragmotion so I will challenge someone else to pick up the gauntlet and finish this so that we may all use the sheer splendour and magnificence that is Blender3D.

I have high hopes for this thread. Anyone?  ::wave
Title: Re: Blender Export Script...
Post by: odnorf on October 23, 2007, 12:12:28 PM
Thanks raychaser.  :)

I made this topic sticky. If anyone improves it in the future please post it here.
Title: Re: Blender Export Script...
Post by: piere on January 06, 2011, 09:14:10 AM
Hey the link doesnt work... does anyone have another link they can post... or any similar programs that would be good?
Title: Re: Blender Export Script...
Post by: Serious.Ray on January 11, 2011, 01:23:36 AM
The exporter shipped with the newest version of Blender 2.5 is quite good. It's still being improved and the developer is going to add the template for the some wintermute engine soon.
That's the link to it.

Settings to make:
The system remains: Left-Handed
If your model is rotated correctly according to the Blender viewports you should uncheck the "Rotate X 90 Degrees" option.
I'm checkin only
"Export Textures"
"Export Armatures"
choose "Animations:" -> "Keyframes Only" (thanks to an update now only the range of the keyframes you set in Blender is exported and not all available keyframes).
You can check "Verbose" to take a look in the console and see if there are any errors exporting it.

It might take some while exporting in which Blender might seem frozen.