Please login or register.

Login with username, password and session length
Advanced search  

News:

IRC channel - server: waelisch.de  channel: #wme (read more)

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - Sothoth

Pages: [1]
1
WME Lite / BASS vs. SDL Mixer
« on: April 27, 2015, 12:30:15 PM »
Hi!

I wonder if I could compile WME Lite to use SDL mixer instead of BASS library and in which platforms will be functional.

Any clues?

Thanks in advance!

2
Bug reports / 3D actor's blocking region doesn't work as expected
« on: July 27, 2013, 12:52:53 AM »
Hi!

I just realized that two 3D actors can collide when they shouldn't. I've tested it using the following scenario:

I have a player character (PC) and a (non-playable character) NPC, two Trinity model copies (from the 3D demo). The player controls one Trinity, and the other Trinity walks automatically from one side of the scene to the other, using the following code:

Code: WME Script
  1. while (true)
  2. {
  3.     trinity2.GoTo(150, 480);
  4.     Sleep(200);
  5.     trinity2.GoTo(600, 480);
  6.     Sleep(200);
  7. }

Both Trinitys have the same blocked regions and waypoints in their .act3d file:

Code: WME Script
  1.   BLOCKED_REGION
  2.   {
  3.       POINT {  0,-50}
  4.       POINT { 500}
  5.       POINT {  0, 50}
  6.       POINT {-500}
  7.   }
  8.  
  9.   WAYPOINTS
  10.   {
  11.       POINT {  0,-55}
  12.       POINT { 550}
  13.       POINT {  0, 55}
  14.       POINT {-550}
  15.   }

I have a very simple geometry (one only walk plane, one camera and one omni light) and the scene has the "2D pathfinding" enabled.

So, if the PC is in any midpoint in the NPC path, and it's still (non-walking) then the NPC circumvents the PC to avoid colliding with it. That's OK.

However, if the PC is in move (walking), the NPC walks through the PC without collision. Moreover, sometimes both PC and NPC ends their walk movements in the same place, and, if this is the case, both PC and NPC gets stuck and they will not move anymore (I suppose that PC enters into the NPC's blocked region and vice versa, so they can't move).

I'm just guessing, but I think the engine doesn't check 3D actor's personal blocked region when in move, or maybe the check is done only once, just before the GoTo(), and never re-check any possible change in any movable blocked region during the GoTo() execution.

2D actor collision detection seems to work OK, though.

Any clues?

Thank you very much in advance.

3
Technical forum / Collisions between multiple actors
« on: July 26, 2013, 05:08:50 PM »
Hi! I'm trying to understand the rationale behind the points in http://docs.dead-code.org/wme/inside_actors.html#collisions , about the BLOCKED_REGION and the WAYPOINTS.

If I'm not wrong, the BLOCKED_REGION defines a 4-point region around the actor, and the WAYPOINTS defines a set of waypoints around the blocked region, so another actor can go near the given actor without entering into its blocked region. All the numbers are relative to the given actor's position.

The above link defines the following blocked region and waypoints:

Code: WME Script
  1.   BLOCKED_REGION
  2.   {
  3.     POINT {-60,-48}
  4.     POINT {46,-48}
  5.     POINT {46,53}
  6.     POINT {-60,53}
  7.   }
  8.   WAYPOINTS
  9.   {
  10.     POINT {-65,-53}
  11.     POINT {-56,39}
  12.     POINT {51,-58}
  13.     POINT {60,58}
  14.   }

However, the waypoint (-56,39) falls into the blocked region, so any other actor will be unable to go to that waypoint. Is it right?

By the way, another question: the blocked region doesn't symetrically surrounds the actor, according to the numbers. It seems to be further away to the left and to the top. Is there a reason to do it so?

Thank you very much in advance!

4
Technical forum / WME1 fork with VSync support
« on: July 25, 2013, 11:02:19 PM »
Hi!

I've just create a fork of the Mnemonic repository in Bitbucket, and I've merge the VSync support from Kinjal sources (from http://kinjal.apeironstudios.com/wme-ke_v2.0_bin_src_26june2012.7z ).

The repository can be found in https://bitbucket.org/ricpelo/wme1 , and my addons/modifications are all in the "alphaaventuras" branch, in https://bitbucket.org/ricpelo/wme1/commits/branch/alphaaventuras .

I've tested it a bit and the VSync support works really good, as far as I can see. With VSync off, the mouse cursor has no lag in fullscreen and all seems to be more responsive. On the other hand, I can't see any perceptive lack of smoothness due to the lack of VSync.

I've tried even with some game demos, like Alpha Polaris, On The Track of Dinosaurs, or Face Noir, as well as the WME 3D demo (as you can see, all 2.5D games; I'm not interested on 2D games for now, sorry). All these games seems to be better with the VSync off.

The relevant commits are a4c53ab (VSync support) and 49cc9b1 (VSync = off by default).

DISCLAIMER! The above changes are totally untested apart from me, and I provide them without warranty of any kind. It's up to you if you use them. Hope this could be useful for somebody :)

Cheers!

5
WME sources discussion / Debug or Release?
« on: July 25, 2013, 03:50:48 PM »
Hi!

Following the (marvellously explained) steps from http://forum.dead-code.org/index.php?topic=5434.0 I just compiled the so called "engine runtime". Because I'm only interested in DX9, I built Debug D3D9 and Release D3D9 only.

My question is: what's the difference between Debug and Release builds? The executable file name is the same in both cases: "wme_D3D9.exe". Which may I use to run my game?

And, do I need another file apart from the .exe file?

Thank you very much in advance! You rock! :)

6
Bug reports / Slow SaveGame() & LoadGame() when in fullscreen?
« on: July 24, 2013, 02:51:47 PM »
Hi! I don't know if this is a known issue (I've done a quick search and I didn't found anything).

Using the wme_demo_3d project, running with 1.10.1beta, "save game" and "load game" features are noticeable much slower in fullscreen rather than in windowed mode. When in fullscreen, you can see a progress bar in the bottom of the screen, from left to right. In windowed mode, save and load are almost instantaneous.

"Maintain aspect ratio" and "Use desktop resolution" options doesn't change anything about this issue.

There isn't a big issue, indeed, but I'd like to know if this is an already reported issue or maybe there's a problem with my system configuration or anything.

Thank you very much!

Sothoth

7
Technical forum / Which WME version must I use?
« on: July 24, 2013, 12:55:23 PM »
Hi! First of all, thank you very much to all of you to stay here and special thanks to the WME creator :).

I'm a totally WME newbie and I'd like to create my first 2.5D adventure game.

My first question is rather simple:

I can see two releases in the WME main webpage: latest release 1.9.1 and latest beta 1.10.1.

Which WME version should I use?

Thank you very much in advance! :)

Sothoth

Pages: [1]

Page created in 0.233 seconds with 16 queries.