Please login or register.

Login with username, password and session length
Advanced search  

News:

Latest WME version: WME 1.9.1 (January 1st, 2010) - download

Author Topic: Incorrect particles FadeOut  (Read 2392 times)

0 Members and 1 Guest are viewing this topic.

Summers

  • Lurker
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 3
    • View Profile
Incorrect particles FadeOut
« on: February 14, 2012, 09:33:08 PM »

Hi everyone. I didnt find that problem to be discussed somewhere so i posted.
While testing particle system abilities i found that particles start to FadeOut only after they finish their path and stop. It's not so bad when FadeOut time is very short, but if we need particle to move and slowly FadeOut like fog, smoke etc ( and I know that most effects in games behave like this) there's a real problem.
So my suggestion is:
-Particle shouldnt stop while FadingOut and die only when FadeOut is finished or
-FadeOut starts at time = particle_LifeTime - FadeOutTime. so the particle fade out before stop.

maybe there's other standart way to solve this problem?
Logged

2.0

  • Regular poster
  • ***
  • Karma: 4
  • Offline Offline
  • Posts: 217
    • View Profile
Re: Incorrect particles FadeOut
« Reply #1 on: June 20, 2012, 02:49:54 PM »

Hi everyone. I didnt find that problem to be discussed somewhere so i posted.
While testing particle system abilities i found that particles start to FadeOut only after they finish their path and stop. It's not so bad when FadeOut time is very short, but if we need particle to move and slowly FadeOut like fog, smoke etc ( and I know that most effects in games behave like this) there's a real problem.
So my suggestion is:
-Particle shouldnt stop while FadingOut and die only when FadeOut is finished or
-FadeOut starts at time = particle_LifeTime - FadeOutTime. so the particle fade out before stop.

maybe there's other standart way to solve this problem?

No, it is necessary to make some fixes in sources to get what you want.
Logged

Summers

  • Lurker
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 3
    • View Profile
Re: Incorrect particles FadeOut
« Reply #2 on: August 13, 2012, 10:55:08 AM »

Hm. it seems i'm the only one who see this bug in  particles. Does anyone uses particles at all?
Logged
 

Page created in 0.148 seconds with 17 queries.