Please login or register.

Login with username, password and session length
Advanced search  

News:

This forum provides RSS feed. To query recent posts use this url. More...


Author Topic: 3D Actor walks too far ahead of shadow and velocity settings  (Read 1799 times)

0 Members and 1 Guest are viewing this topic.

Barry Burton

  • Lurker
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 13
    • View Profile
3D Actor walks too far ahead of shadow and velocity settings
« on: January 11, 2013, 07:59:47 AM »

Firstly, I'm using 3D Studio Max to rig and animate Chris Redfield as a test and using the Pandasoft Exporter with the directions on this site, while the idle animations loaded smoothly, the walking is completely broken. My character is walking way ahead of the velocity settings defined in the Actor3D file and WAY ahead of his shadow.



His walking animations go forward along the grid in 3D Max and do not stay in one place, but I don't want that happening in WME, I want him to walk in place according to the shadow and the velocity settings.

Are there any settings that I can use within WME to fix this? Or will I have to figure out what the cause is within 3D Max itself?
Logged

Mnemonic

  • WME developer
  • Administrator
  • Addicted to WME forum
  • *
  • Karma: 41
  • Offline Offline
  • Gender: Male
  • Posts: 5675
    • View Profile
    • Dead:Code Site
Re: 3D Actor walks too far ahead of shadow and velocity settings
« Reply #1 on: January 11, 2013, 08:13:15 AM »

Or will I have to figure out what the cause is within 3D Max itself?
Yes. You need to remove the appropriate movement keyframes so that the walking animation is happening in-place.
Logged
Yes, I do have a twitter account
Please don't send me technical questions in private messages, use the forum. ::wave
 

Page created in 0.176 seconds with 17 queries.