Please login or register.

Login with username, password and session length
Advanced search  

News:

Latest WME version: WME 1.9.1 (January 1st, 2010) - download

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - Birdline

Pages: [1]
1
Technical forum / General limitation (names, tree folders)
« on: December 23, 2008, 11:04:44 AM »
Having in mind game speed or may be compile errors,

Are they any limits for general long names (variable/scene/sprite...) or depth of tree folders?

I mean using: ObjectPositionVertical insread of just ObjPV (for some variable name),
or Scene_First_Time_There (for some scene/object name),
and having many folders/subfolders/subfolders for scenes/objects location,

This will end up to really long file name and location (depth Dir).
Is this a problem, for any reason?

Best regards,
Spyros

2
Technical forum / Global, Local variables and memory
« on: December 09, 2008, 05:08:22 PM »
A new be question.
1. I can declare a global variable in base.inc, so it is available through the whole game without having to "declare" it again (right?).
2. I can declare a global variable in an other "local" script, so it is also available to other scripts, if I "declare" it again (right?).
What is the difference from memory side?
As I can understand it, in first case the variable is stored in memory and stays there until I quit the game.
What happens in second case?
And what about in case of Local variables (and memory)?

Best regards,
Spyros

3
Technical forum / Infinite loop and performance
« on: December 09, 2008, 02:53:17 PM »
I have a small script with a loop (infinite).
It just checks the health of the actor and ends the game.
It is some thing like this:
while(1)
{
if the actor's health is something
then the game is over
}
My question:
What is the difference in game performace in the following 2 cases?
Case 1: I attach/detach this script when ever I need it
Case 2: I attach this in game script so it is always running

Best regards,
Spyros

4
Technical forum / Wide Screen (WME 1.8.8)
« on: December 06, 2008, 12:17:48 PM »
I don't know if I should post this here but, I am testing the new beta WME 1.8.8.
I started 2 games, 1024X768 and 1440X900.
Both use the same .3ds geometry.
Have no problem with 1024X768,
but for 1440X900 I must manually set the camera's FOV (some thing like 36.32).
Only if I do this the geometry works OK.
Is this normal?

Best regards,
Spyros

5
Technical forum / Window method
« on: December 05, 2008, 09:34:27 PM »
I will try to explain one problem I have.
I have a window that is loaded in game script (hidden for some scenes, visible for some others).
This window has (among others) one static object that must be moving from one side to the other.
This movement must start when ever I click on an object in a scene and must stop when ever I click on an other object.

So, I made a method for the window which takes care of the movement (usual loop) and checks if a trigger is true.
For the objects, one sets the trigger to true and calls the method, and the other simply stops the trigger.
This is working fine, but I have this problem.

1. I am in Scene A,
2. I start the trigger (click on object_1),
3. the movement starts,
4. I move to Scene B,
5. the movement continues,
6. I stop the trigger (click on object_2),
7. the movement stops.

Every thing seems OK, BUT
Looking at the Debug console I see that the method is still there  ???

If I do the same again, then another method is stucked after the previous and so on.
At any time the movement is happening normally.

I don't have this issue if I don't change scene.
I mean that if I start/stop the trigger in the same scene,
at the Debug console the method clears each time the trigger is stoped.

Spyros

6
Technical forum / Caption window
« on: November 28, 2008, 08:42:07 PM »
Hi all,
I have a problem with caption window.
My captions are shown at the top of the screen and they have a background image.
They appear each time the mouse is over an interactive object (default behavior).

The problem is this.
When the mouse is over the inventory, the caption window is always visible.
I mean that if there is an item, I see the item's name and the background image (normal),
but if there is no item (empty slot), I see only the background image (not very nice).
I would like the caption window to be hidden (no text no image) if the mouse is over an empty slot in the inventory.
How can I do this?

BTW, I had the same problem with buttons in some other windows,
but I solved that by checking if the active object is a "button" and then hide the caption.
I tried to do the same with inventory, but I don't know how to check if a slot is empty or not.

Best regards,
Spyros

7
Technical forum / Saturation
« on: November 23, 2008, 12:59:11 AM »
Hi all,
I wonder if it is possible to change the saturation of an object (or even the whole scene).
I mean to change it from color to grayscale (B&W).
Using the MakeRGBA or MakeHSL, only give me a color tint not a greyscale effect.

Best regards,
Spyros

8
Technical forum / Scene_init script and Object script
« on: November 21, 2008, 11:56:51 AM »
Hi all,
As a newbe, I have a problem.

In a scene, I can move/rotate objects with the mouse and position them where ever I want.
This is controlled by the object's script (LeftClick, LeftRelease).
What I want to do is this.
When I move an object to a certain position, something must be done.

So I write a contition.

if (this.X<= somenumbers && this.Y==somenumber && ......)
{
   do something
}

The problem is that if I write this at the objects script (LeftRelease), it is working OK.
But if I write the contition at the scene_init.script, it does not.

In the scene_init.script, I used:

var Object1 = Scene.GetNode("objectname") //to get control of the object,
and the contition changed as:
if (Object1.X<= somenumbers && Object1.Y==somenumber && ......)
{
   do something
}

I must say that in scene_init.script, using Game.Msg(Object1.X) and Game.Msg(Object1.Y),
I see the updated position of the object.
But the contition doesn't work.

Any help?
Spyros

9
Technical forum / No speech in compiled game
« on: November 04, 2008, 09:34:52 AM »
Hi all,

I'm tottaly new here,  :), so I have a newbe problem.
I wanted to use the auto speech feature of WME, so I used the string table utility and made my string.
I have a package with some speech files named "greek". I added this dir with AddSpeechDir.
Well when in Project Editor (F5), everything works fine. The actor automatically says the correct audio files (eg 0001.ogg).
But, when I compile the game, I have no speech at all.
Am I doing something wrong?

Best regards,
Spyros

Pages: [1]

Page created in 0.047 seconds with 18 queries.