Please login or register.

Login with username, password and session length
Advanced search  

News:

This forum provides RSS feed. To query recent posts use this url. More...


Author Topic: wme 1.8  (Read 4012 times)

0 Members and 1 Guest are viewing this topic.

SBOVIS

  • Frequent poster
  • ****
  • Karma: 0
  • Offline Offline
  • Gender: Male
  • Posts: 404
  • FORGET REALITY SURRENDER TO YOUR DARKEST DREAMS
    • View Profile
    • LIMBO of the LOST
wme 1.8
« on: September 26, 2007, 12:10:46 PM »

Hi many thanks for the update and all the new functions. I have one question that may also be interesting to others, what difference to a 2D project would switching to 1.8 with direct x9 instead of direct x8 make?

Will speed be impoved regarding screen updates for sprites, scene entities, theora etc?

 ::rock
Logged
kind Regards
Steve Bovis
MAJESTIC STUDIOS

Mnemonic

  • WME developer
  • Administrator
  • Addicted to WME forum
  • *
  • Karma: 41
  • Offline Offline
  • Gender: Male
  • Posts: 5683
    • View Profile
    • Dead:Code Site
Re: wme 1.8
« Reply #1 on: September 26, 2007, 12:20:03 PM »

Currently only 2.5D games with hardware transform&lighting enabled will see considerable performance improvement when using D3D 9. There's no point in switching to D3D9 for 2D games.
Logged
Yes, I do have a twitter account
Please don't send me technical questions in private messages, use the forum. ::wave

TheDerman

  • Regular poster
  • ***
  • Karma: 0
  • Offline Offline
  • Posts: 225
    • View Profile
Re: wme 1.8
« Reply #2 on: September 26, 2007, 01:54:19 PM »

Does 1.7.3 use D3D8?

I mean, I'm currently using 1.7.3, so which version of D3D am I using?
Logged

odnorf

  • w00t?
  • Global Moderator
  • Addicted to WME forum
  • *
  • Karma: 7
  • Offline Offline
  • Gender: Male
  • Posts: 1456
  • Lamp dog!
    • View Profile
Re: wme 1.8
« Reply #3 on: September 26, 2007, 02:06:34 PM »

1.7.3 is D3D8 only.
In 1.8 you can choose between D3D8 or D3D9. So there is no reason not update.
Logged
fl*p

Mnemonic

  • WME developer
  • Administrator
  • Addicted to WME forum
  • *
  • Karma: 41
  • Offline Offline
  • Gender: Male
  • Posts: 5683
    • View Profile
    • Dead:Code Site
Re: wme 1.8
« Reply #4 on: September 26, 2007, 02:07:58 PM »

All the previous versions are using D3D8. Version 1.8 lets you choose whether to use D3D8 or D3D9.
In any case, I'd recommend upgrading to 1.8 even if you don't use this particular feature. There are many other bugfixes and improvements.

EDIT: odnorf was faster.
Logged
Yes, I do have a twitter account
Please don't send me technical questions in private messages, use the forum. ::wave

TheDerman

  • Regular poster
  • ***
  • Karma: 0
  • Offline Offline
  • Posts: 225
    • View Profile
Re: wme 1.8
« Reply #5 on: September 26, 2007, 02:43:42 PM »

Thanks. I'm going to update. Just wanted to know is all.  8)
Logged
 

Page created in 0.029 seconds with 19 queries.