Please login or register.

Login with username, password and session length
Advanced search  

News:

This forum provides RSS feed. To query recent posts use this url. More...


Author Topic: turn off animation blending  (Read 4086 times)

0 Members and 1 Guest are viewing this topic.

Dan-D

  • Occasional poster
  • **
  • Karma: 0
  • Offline Offline
  • Posts: 89
    • View Profile
turn off animation blending
« on: May 18, 2008, 11:43:00 PM »

Hey guys! 3d actor animation blending sometimes really annoying, is there some way to disable it? Or I'll have to use Actor.PlayAnimChannel for this?
Logged

Mnemonic

  • WME developer
  • Administrator
  • Addicted to WME forum
  • *
  • Karma: 41
  • Offline Offline
  • Gender: Male
  • Posts: 5683
    • View Profile
    • Dead:Code Site
Re: turn off animation blending
« Reply #1 on: May 19, 2008, 07:40:52 AM »

See actor.SetAnimTransitionTime() method in the documentation. That should help you.
Logged
Yes, I do have a twitter account
Please don't send me technical questions in private messages, use the forum. ::wave

Dan-D

  • Occasional poster
  • **
  • Karma: 0
  • Offline Offline
  • Posts: 89
    • View Profile
Re: turn off animation blending
« Reply #2 on: May 19, 2008, 12:30:05 PM »

Yes I've tried that. But there are still transition. Here init script
Code: [Select]
#include "scripts\base.inc"

// here comes the stuff which initializes the scene

if(!Game.IsMusicPlaying()) Game.PlayMusic("music\basement1.ogg");
actor.SetAnimTransitionTime("b_1_1", "b_1_2", 0);
Game.Interactive = false;
Game.PlaySound("voice\basement_cut1_1.ogg", false);
actor.SkipTo(736, 218);
actor.Direction = DI_LEFT;
actor.Active = true;
actor.PlayAnim("b_1_1");
Game.ChangeScene("scenes\Basement\scene1_cut2\scene1_cut2.scene", false, false);
actor.UnloadAnim("b_1_1");
Logged

Eshaktaar

  • Lurker
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 14
    • View Profile
Re: turn off animation blending
« Reply #3 on: May 19, 2008, 01:45:39 PM »

Have you tried actor.AnimTransitionTime = 0?
Logged

Mnemonic

  • WME developer
  • Administrator
  • Addicted to WME forum
  • *
  • Karma: 41
  • Offline Offline
  • Gender: Male
  • Posts: 5683
    • View Profile
    • Dead:Code Site
Re: turn off animation blending
« Reply #4 on: May 19, 2008, 02:56:39 PM »

I don't see the "b_1_2" animation called anywhere in the code. You kill the first animation right after playing.
Logged
Yes, I do have a twitter account
Please don't send me technical questions in private messages, use the forum. ::wave

Dan-D

  • Occasional poster
  • **
  • Karma: 0
  • Offline Offline
  • Posts: 89
    • View Profile
Re: turn off animation blending
« Reply #5 on: May 19, 2008, 06:23:39 PM »

I don't see the "b_1_2" animation called anywhere in the code. You kill the first animation right after playing.
Yep. b_1_2 called from another scene...
Indeed it was because of actor.UnloadAnim command... Thanks for helping!
Logged
 

Page created in 0.02 seconds with 19 queries.