Please login or register.

Login with username, password and session length
Advanced search  

News:

Latest WME version: WME 1.9.1 (January 1st, 2010) - download

Author Topic: Russian characters in window "edit" component  (Read 5387 times)

0 Members and 1 Guest are viewing this topic.

metamorphium

  • Global Moderator
  • Addicted to WME forum
  • *
  • Karma: 12
  • Offline Offline
  • Gender: Male
  • Posts: 1511
  • Vampires!
    • View Profile
    • CBE  software s.r.o.
Russian characters in window "edit" component
« on: September 28, 2007, 10:20:56 AM »

Hi,

I am not able to get correct keyboard input into edit component in the window. I set the correct ttf font with CHARSET = 10 and
all texts in the game work fine. When player has to enter the savegame filename though he sees only garbage. I tried it myself
and upon setting russian keyboard, it produces little squares instead of characters.

Am I missing something? I can of course workaround it with automatic savegame naming, but I'd prefer the old functionality.

Thanks for any help with this.
Logged
J.U.L.I.A. Enhanced Edition, Vampires!, J.U.L.I.A., J.U.L.I.A. Untold, Ghost in the Sheet

Mnemonic

  • WME developer
  • Administrator
  • Addicted to WME forum
  • *
  • Karma: 41
  • Offline Offline
  • Gender: Male
  • Posts: 5683
    • View Profile
    • Dead:Code Site
Re: Russian characters in window "edit" component
« Reply #1 on: September 28, 2007, 11:02:49 AM »

Yes, unfortunately the editor control doesn't cope well with utf-8 mode and non-ASCII characters.
Logged
Yes, I do have a twitter account
Please don't send me technical questions in private messages, use the forum. ::wave
 

Page created in 0.017 seconds with 25 queries.