Please login or register.

Login with username, password and session length
Advanced search  

News:

This forum provides RSS feed. To query recent posts use this url. More...


Author Topic: Run WME with OS X Wine  (Read 3834 times)

0 Members and 1 Guest are viewing this topic.

Purpur

  • Lurker
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 10
    • View Profile
Run WME with OS X Wine
« on: December 23, 2011, 03:45:08 PM »

Hi!

I'm working on a Mac (Lion) and running WME on Windows via BootCamp works fine of course.
But i just tried to install WME on my Mac partition with WineBottler to avoid rebooting the computer every time i wanna work on my project.
Installing WineBottler and WME worked both fine, but right after that, when i try to start up wme.exe, an error message occurred.
It says:
Einige notwendige Spieldateien können nicht geladen werden. Bitte installieren Sie das Spiel erneut und versuchen Sie es noch einmal.

In english it would be something like:
Some necessary game files couldn't be loaded. Please reinstall the game and try it again.

Already reinstalled WME, but the problem persists.

Google couldn't help, and i don't find any tutorials for installing WME on a Mac, let alone a solution for that problem.
But as far as i know, WME should run fine with Wine in some degree - at least i thought it should.

Any ideas? Thanks in advance!

Greets
Logged

odnorf

  • w00t?
  • Global Moderator
  • Addicted to WME forum
  • *
  • Karma: 7
  • Offline Offline
  • Gender: Male
  • Posts: 1455
  • Lamp dog!
    • View Profile
Re: Run WME with OS X Wine
« Reply #1 on: December 23, 2011, 04:35:21 PM »

That message means that you run wme.exe and the engine can't find game data (compiled or not). Do you get it when compiling and running a game or when trying to run a game through project manager?
Logged
fl*p

Purpur

  • Lurker
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 10
    • View Profile
Re: Run WME with OS X Wine
« Reply #2 on: December 23, 2011, 06:16:44 PM »

Hi!

Thanks for your reply.
Neither nor.
I get this message instantly when i'm trying to start up the project manager (wme.exe).
I can't even get WME running, so to say there's no WME-related game existing yet.
Logged

Mnemonic

  • WME developer
  • Administrator
  • Addicted to WME forum
  • *
  • Karma: 41
  • Offline Offline
  • Gender: Male
  • Posts: 5683
    • View Profile
    • Dead:Code Site
Re: Run WME with OS X Wine
« Reply #3 on: December 23, 2011, 06:31:47 PM »

wme.exe is not Project Manager, that would be ProjectMan.exe. You can't run wme.exe with no game data, that's why you're getting the error message.
Logged
Yes, I do have a twitter account
Please don't send me technical questions in private messages, use the forum. ::wave

Purpur

  • Lurker
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 10
    • View Profile
Re: Run WME with OS X Wine
« Reply #4 on: December 23, 2011, 07:50:24 PM »

Oh my god, you're right! Sorry.
Alright, now WME starts up, but the problem now is that i can't open my project files.
I choose "open", browse to my project folder (it's in my documents folder), where i click on "rott.wpr". But nothing happens, WME freezes and i can't click on anything anymore.
The only thing i can do is click on the red X (the upper left corner of the window) to close the whole application, but within WME there's nothing i can do.

At first i thought it's because there is some kind of a virtual Windows directory inside of the Wintermute package.
Because when i open the finder, browse to my applications folder, rightclick on Wintermute and then "Show package contents", there is a c:\ with those standard Windows folders.
But i also tried to copy my project folder into the Wintermute package, so that it's stored in the Windows directory.
Doesn't work either, same problem.

At last i tried to open a new project.
So in WME i clicked on "new", entered a project name and clicked "ok". But then there is the same problem again ... WME freezes.

So it seems WME isn't able to open a project in general.
Bad thing ...

PS:
But running a compiled WME game works fine and without any problems.
Logged

Mnemonic

  • WME developer
  • Administrator
  • Addicted to WME forum
  • *
  • Karma: 41
  • Offline Offline
  • Gender: Male
  • Posts: 5683
    • View Profile
    • Dead:Code Site
Re: Run WME with OS X Wine
« Reply #5 on: December 24, 2011, 01:00:20 PM »

Hm, I think it hangs at the moment when ProjectMan initializes the Direct3D view. No advice here, sorry. I know some people run ProjectMan using Wine in Linux, but I don't know how the compatibility is in OSX.
You can try checking the ProjectMan.log file, it should be generated in the project directory.
Logged
Yes, I do have a twitter account
Please don't send me technical questions in private messages, use the forum. ::wave

Purpur

  • Lurker
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 10
    • View Profile
Re: Run WME with OS X Wine
« Reply #6 on: December 24, 2011, 03:11:56 PM »

There's only one ProjectMan.log file i could find with Spotlight search, and it contains logs from the 30th of October until yesterday evening, when i started up a compiled WME-game with wine.
I'm afraid it's not the correct log file, maybe wine-WME couldn't log my attempts opening a project, because it freezed.
But i copied out the last few logs:


18:54: ********** DEBUG LOG OPENED 23-12-2011 (Release Build) *****************
18:54: Wintermute Engine ver 1.9.1, Compiled on Jan  1 2010, 09:46:49
18:54: Platform: Windows XP Service Pack 3 (Build 2600)
18:54: DirectX version: 9.0
18:54:
18:54: Scanning packages...
18:54:   Registered 0 files in 0 package(s)
18:54: Initializing scripting engine...
18:54:   Script compiler bound successfuly
18:54: Loading plugins...
18:54:   wme_sample_pixel.dll
18:54:   wme_snow.dll
18:54:   wme_aMUSE.dll
18:54: Scanning packages...
18:54:   Registered 0 files in 0 package(s)
18:54: Enumerating Direct3D devices...
18:54: Enumerating DirectSound devices...
18:54: Game aspect ratio:    -1.#IND00
18:54: Monitor aspect ratio: 1.805360
18:54: Game aspect ratio is the same as monitor aspect ratio.
18:54: Backup resolution:  0 x 0
18:54:
18:54: Available video devices:
18:54:   ATI Radeon HD 4600 Series (accelerated)
18:54:     Driver: ati2dvag.dll 6.14.10.6764
18:54:     Monitor: 0
18:54: Available audio devices:
18:54:   Primary Sound Driver
18:54:   Built-in Output
18:54:   [no sound]
18:54: Auto selecting devices for windowed mode:
18:54:   Video: ATI Radeon HD 4600 Series (accelerated)
18:54:          Windowed:yes  Colors:16bit  T&L:no  Multisample:0
18:54:   Audio: Primary Sound Driver

19:10: ********** DEBUG LOG OPENED 23-12-2011 (Release Build) *****************
19:10: Wintermute Engine ver 1.9.1, Compiled on Jan  1 2010, 09:46:49
19:10: Platform: Windows XP Service Pack 3 (Build 2600)
19:10: DirectX version: 9.0
19:10:
19:10: Scanning packages...
19:10:   Registered 0 files in 0 package(s)
19:10: Initializing scripting engine...
19:10:   Script compiler bound successfuly
19:10: Loading plugins...
19:10:   wme_sample_pixel.dll
19:10:   wme_snow.dll
19:10:   wme_aMUSE.dll
19:10: Scanning packages...
19:10:   Registered 0 files in 0 package(s)
19:10: Enumerating Direct3D devices...
19:10: Enumerating DirectSound devices...
19:10: Game aspect ratio:    -1.#IND00
19:10: Monitor aspect ratio: 1.805360
19:10: Game aspect ratio is the same as monitor aspect ratio.
19:10: Backup resolution:  0 x 0
19:10:
19:10: Available video devices:
19:10:   ATI Radeon HD 4600 Series (accelerated)
19:10:     Driver: ati2dvag.dll 6.14.10.6764
19:10:     Monitor: 0
19:10: Available audio devices:
19:10:   Primary Sound Driver
19:10:   Built-in Output
19:10:   [no sound]
19:10: Auto selecting devices for windowed mode:
19:10:   Video: ATI Radeon HD 4600 Series (accelerated)
19:10:          Windowed:yes  Colors:16bit  T&L:no  Multisample:0
19:10:   Audio: Primary Sound Driver





PS:
Merry X-Mas!
Logged
 

Page created in 0.023 seconds with 20 queries.