Please login or register.

Login with username, password and session length
Advanced search  

News:

Latest WME version: WME 1.9.1 (January 1st, 2010) - download

Author Topic: Animation Events Problem  (Read 2660 times)

0 Members and 1 Guest are viewing this topic.

Derrek3D

  • Occasional poster
  • **
  • Karma: 0
  • Offline Offline
  • Posts: 82
    • View Profile
Animation Events Problem
« on: December 09, 2007, 03:51:53 PM »

I have a problem with my 3D actor's animation events. My event handlers are being called twice: once at the correct frame and the other after the animation ends. Is this a known issue/bug or am I doing something wrong?

My animation is defined like this in my actor's act3d file:

Code: [Select]
ANIMATION
{
    NAME="DoSomething"

    EVENT
    {
        FRAME = 50
        NAME = "DoSomething"
    }
}

And in the actor's script I have a:

Code: [Select]
on "DoSomething"
{
    Game.Msg("DoSomething");
}

The game outputs the "DoSomething" to the screen at the correct frame during the animation and then it outputs it again after the animation ends. Any ideas?
Logged

Mnemonic

  • WME developer
  • Administrator
  • Addicted to WME forum
  • *
  • Karma: 41
  • Offline Offline
  • Gender: Male
  • Posts: 5676
    • View Profile
    • Dead:Code Site
Re: Animation Events Problem
« Reply #1 on: December 09, 2007, 04:25:32 PM »

It's a bug introduced in the last version. The event is incorrectly triggered again when transitioning to another animation. I fixed it, thanks for reporting.
Logged
Yes, I do have a twitter account
Please don't send me technical questions in private messages, use the forum. ::wave

Derrek3D

  • Occasional poster
  • **
  • Karma: 0
  • Offline Offline
  • Posts: 82
    • View Profile
Re: Animation Events Problem
« Reply #2 on: December 09, 2007, 04:37:53 PM »

Ok, great! Thanks for fixing it.
Logged
 

Page created in 0.255 seconds with 18 queries.