Please login or register.

Login with username, password and session length
Advanced search  

News:

This forum provides RSS feed. To query recent posts use this url. More...


Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - plobone

Pages: [1] 2
1
Technical forum / How to handle Loops and FPS questions
« on: March 13, 2014, 08:14:16 PM »
Hello there!!

I'm experimenting a little bit with the idea of making an action adventure game and I
have a few questions refering to while loops.

The game will be a third person view, the camera will follow constantly the character.

The cursor will help to move the actor in the scene, pick up objects, talk to entities, change scenes.
ButI want while im pressing down the TAB key the simple cursor to transform to weapon
cursor and kill enemies when click on them...After I release TAB key the cursor will
transform back to normal and do the regular actions.


I have achieved that by making a while loop in a new script file, in the script folder of
project manager. Also I have another script file with a while loop that controls the
camera movement.

---And I was wondering is this the correct way to handle the loops?

---Should I put both of these loops in one script file?These are loops that will run all the time in the game.

---Also I was checking the fps rate... only for one second in the startup of the game the framerate
is 60 and after that goes 250+ ...This happended from the moment I made the while loop for the camera.
That kind of frame rate is normal??

Thank you very much for your time!
CHeEERRZZz

 

2
Game announcements / Re: The Ancient Mark - Episode 1
« on: November 19, 2012, 05:09:36 PM »
Quote
Also, it would be nice to be able to skip the captions with a left click - I kept clicking the soil all the time at the start to see if anything different was said, but it was the same caption, so had to wait for the caption to disappear each time. could get frustrating.

And finally, would be good to be able to click past the logos at the start.

Hello again!
Now you can skip the logos, and with right click you skip the captions!
Also the game has been published in Desura you can check it out!

3
Game announcements / Re: The Ancient Mark - Episode 1
« on: October 20, 2012, 10:41:32 AM »
Few things though - the captions don't stay on screen long enough to read them, so you have to keep clicking them to be able to read the whole thing. And if the caption changes from the first click to the second, then you'll miss what was said the first time round. This happened with the marbles at the start.

Also, it would be nice to be able to skip the captions with a left click - I kept clicking the soil all the time at the start to see if anything different was said, but it was the same caption, so had to wait for the caption to disappear each time. could get frustrating.

And finally, would be good to be able to click past the logos at the start.


Thanks for the comments!
hehe...I knew that length/time and that you can't skip the captions could be a little bit frusrtating but I wanted so much to release the game :)
I will fix it in the future!

4
Game announcements / Re: The Ancient Mark - Episode 1
« on: October 19, 2012, 05:05:20 PM »
pretty cool game

Hey thank you!
All our firends that made the testing and played it, found it difficult as a game.
I would love to listen your opinions.
 

5
Game announcements / Re: The Ancient Mark - Episode 1
« on: October 19, 2012, 11:25:22 AM »
Wow! Cool graphics :)

Thank you very much!

By the way, if anyone finds bugs/errors contact me, I will try to fix it!   

6
Game announcements / The Ancient Mark - Episode 1
« on: October 18, 2012, 05:30:36 PM »
Hello everyone!

We (me and my bro) finally released the first small episode of a game that we've being working for a long time now.Thank you all, because without your posts and informations Im sure that we couldn't do anything.

The game is free to download and you can find all the usefull links below:

http://www.theancientmark.com
http://www.facebook.com/theancientmark

keePiTUp!

7
Technical forum / Re: Compiled package size question
« on: August 08, 2012, 07:28:10 PM »
White Chamber - Great Game - Very Short - 360MB :)

lol yea I've checked that already!
I have made my research befeore posting! ;)

8
Technical forum / Re: Compiled package size question
« on: August 08, 2012, 07:16:53 PM »
Hi!!

Thanks for the tip about "Compression=lzma/ultra , SolidCompression=yes".... I ll check it out!
YAp I though about reduse the quality of the graphics/sounds but I don't think is a good idea... I've lower the quality as much as it could take  ;)

And these days...what are 300-400 megs? Nothing. People are downloading 10 gigs of data when buying a game online..,.so what :)
You are right...I was  little bit afraid that maybe the game is very small...and the package too big...

Thank you very much for the info!
 


9
Technical forum / Compiled package size question
« on: August 08, 2012, 05:14:29 PM »
Hello everyone! :)

Just finished a game with wintermute and I have 1-2 questions...
I complide the game in wintermute and I saw that the size of the compiled package is 390mb
After that I made a setup for the game with the inno setup...and the setup.exe was 378mb

The Resolution of the game is 1024x768 and some rooms have bigger dimensions
The game has 26 rooms
Several small png sprites
5 videos/cutscenes each of 1 minute.
The estimate time of the gameplay is 2,5/3 hours.

I know that I dont give you lot of information...but I though that you may give me a hint from your experience.

Do you think that the size of the finalle setup package is big?

If the package is big...
Can I reduse/compress the size of it some how...even with wintermute or with inno?
Or I must simple reduse the size of my jpegs that I use in the game project?

Thanks a lot!


10
Technical forum / Re: Window inactive
« on: February 05, 2012, 03:27:09 PM »
OOooo god!!!!!

Yea I did try to control my inventory with the Tab key from the game.script but it didn't work the first time!
and I though that it wasn't the correct way to do it ....so I read some post here and started to make the window with the button to control it.

But as you said the best way to control the tab key is to put it in the game.script and I try it again.....BUT you don't have to put a second keypress event (I already have one for the Esc button) just in the same keypress event you put the the tad key!!! and it works great!!!

Thank YOUUUUUU Mnemonic!!!
After spending to days just for the inventory button!!!! Lets drinnk a beerrrr  ::beer

 

11
Technical forum / Window inactive
« on: February 05, 2012, 02:40:07 AM »
Hello everyone

I have just made a window with a button inside so every time i press the button the inventory will appear and disappear.I also set up a Keypress event, every time you press the tab key do the same.
Everything works coooolll but...

When I tryed this in a scene that it had several active entities and regions...every time I move the mouse over in those entities or regions the window(with the button inside) somehow disabled or set itself inactive.

If I click with the mouse the button, inventory will appear and disappear, but when I press the tab key wont work because the window is inactive all the time.

Do I need some code so that the window should be active all the time?
Do I miss something in window editor?


if the there is a post with the same problem and I missed it I'm sorry!giveme a link to check it out.
Thank you!

12
Technical forum / Re: Sprite sound problem
« on: January 26, 2012, 08:33:26 PM »
Fixed!

I've set the entity with the sounds inactive and placed infront of it another entity with no sounds active.
When you click the entity with no sound you make it inactive... and you load into the scene the entity with the sound.

Thanks again!

13
Technical forum / Re: Sprite sound problem
« on: January 26, 2012, 07:49:42 PM »
Thank you very Mnemonic!
I think Ill try the first option!:)


14
Technical forum / Sprite sound problem
« on: January 25, 2012, 07:13:14 PM »
hello wintermuterssss

here is my problem:

I've got a scene with one entity.
The entity inside it has 6 sprites, all the sprites have a specific sound(I linked the sounds within the sprite editor)
the entity is like a switch or a knob every time you click on it, change sprite and make a sound.(I manage to do this with a script that I found here: http://forum.dead-code.org/index.php?topic=2946.msg18609#msg18609 )


But the thing is that every time I get inside the scene, the first sound of the first sprite of the entity plays.(without click on the entity)

If you could tell me away to fix this. I've tried several things that I found here...but I'm not really good in codeing.

Thank you all for your time!:)

15
Scripts, plugins, utilities, goodies / Re: Source Code for a Word Puzzle
« on: January 17, 2012, 08:15:30 PM »
EDIT: Ok I fixed it!! :)


Hello there!!

I know that this is an old topic but I've just download the word puzzle
and wanted to check it out in a puzzle that I make with new graphics.

Soooo I made all the necessary changes but instead of using
.jpg format for the sprites and square shaped tablets for my letters
I've used .png format for the sprites because my letters are in circle shape.....

And nothing works correct...I can pick up a letter, but I can't place it in any slot or drop it down.
When I convert my letters in .jpg format the puzzle works just fine....

It has something to do with the alpha and the transarency?
I've checked the manual of wme and supports .png files ....
I have to change something in the script so wme can understand that my sprite has transparency?

Thank you very much!
and thanks for the code Catacomber! :)

Pages: [1] 2

Page created in 0.031 seconds with 19 queries.