Please login or register.

Login with username, password and session length
Advanced search  

News:

IRC channel - server: waelisch.de  channel: #wme (read more)

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - chris974

Pages: [1]
1
Thanks - sorry about that. The sprites were also part of the background so i couldn't see the difference. I couldn't get it to print an error, but i re-imported the sprites and it worked fine.

2
Hi, sorry if this is a known issue or a noob mistake. I tried a search of the forum but couldn't find the right words to search on...

Basically, my zsorting, walking behind sprites etc works fine within the editor JIT compiled version of the game. As soon as I compile the game it stops working and my actor floats on top of everything.  I think it may have something to do with using the 'direct draw' mode when i'm in the editor. I was given a registry entry to force this on my VM which i use to edit.

I tested the compiled game in linux under wine, and in a physical windows xp box with graphics acceleration - same result on both, the character floats. By the way I'm entirely using 2d sprites here.

Ah.. actually, i just tested the compiled game in my VM and it DID work fine just like in the editor.. so its just down to the different environments. Because it gives the same result in linux and windows, it seems like maybe my registry key (or some other factor) is affecting the compiler and it compiles a game that only works correctly using Direct Draw, OR there is some kind of conflict with my graphics card? (or else i've managed to stuff up 2 completely different environments some how, which is not necessarily out of the question)

Let me know if there is any more info i can give to assist - or anything i can test.


3
Technical forum / Re: ANN: Dropping support for DirectDraw
« on: May 16, 2008, 03:03:00 PM »
Just added this and it works perfectly. Thanks so much for the quick response - the level of support is encouraging. Looking forward to getting stuck into my project.


4
Technical forum / Re: ANN: Dropping support for DirectDraw
« on: May 16, 2008, 02:05:34 PM »
Hi - i'm very new to Wintermute engine. I very much like the look of it so far - but just trying to get started at the moment. Although I have a recent computer, i'd like the ability to use (and test) the editor in a VMWare windows XP. I'm only looking to make a 2d game - and was trying to figure out how to run it without requiring 3d acceleration.

Basically - VMWare can't utilise the 3d card so WME doesn't see it. I can run a 2d Wintermute game fine on the vmware windows instance - but when I try to run a game from the editor (F5) it gives me no option and says it requires 3d acceleration. I looked everywhere for options to not use 3d acceleration in the editor - before searching and finding these posts. I understand from this announcement that 3d acceleration is now required - but apparently the old direct draw stuff is still availalble in "troubleshoot options"? I haven't been able to find anything about the trouble shoot options in the editor menus or the options when trying to run a game - is there something that i have to manually add to a configuration file?

In the end i'm not worried about the game requiring 3d acceleration but would like to be able to override that just for purposes of development. Alternatively.. maybe there is a slightly older version of the engine I could use? But from what i can tell older versions aren't available for download.


Pages: [1]

Page created in 0.037 seconds with 20 queries.