Please login or register.

Login with username, password and session length
Advanced search  

News:

Forum rules - please read before posting, it can save you a lot of time.

Pages: [1] 2  All

Author Topic: Is IE necessary application? There is a problem in Linux.  (Read 10798 times)

0 Members and 1 Guest are viewing this topic.

Dionysius

  • Frequent poster
  • ****
  • Karma: 3
  • Offline Offline
  • Gender: Male
  • Posts: 361
    • View Profile
    • On the Tracks of Dinosaurs
Is IE necessary application? There is a problem in Linux.
« on: March 31, 2005, 04:21:28 PM »

I work in ASPLinux 9.0 (based on RedHat 9.0) and I cannot make new or open existing project. I get the message:
Quote
This application is requesting an ActiveX browser object but the Mozilla ActiveX Control is currently not installed. Do you wish to download and install it?
When I choose "Yes" the downloading process does not begin. I downloaded and installed the Mozilla ActiveX Control 1.7.1 for Windows but it did not help. What can I do else? IE is not freeware program, isn't it?
And how compile the wme_demo? The comand line is "wme_comp.exe -project project.wpr -script script.dcs [-output output_path]" but there are not any *.dcs file in wme_demo. In FAQ written that a WME game must have only *.exe file if I want to play in linux. But when I try to run wme.exe in Cedega I get the message
Quote
Some of the essential game files cannot be loaded. Please reinstall the game and try again.
And in shell is written
Quote
err:module:import_dll Library msdbi.dll (which is needed by L"C:\\Program Files\\WME DevKit\\IMAGEHLP.dll") not found
Please, help me to run this engine and its games in linux.
Logged

Nihil

  • Supporter
  • Addicted to WME forum
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 528
  • Fear me! I'm evil!
    • View Profile
    • Order of Dagon
Re: Is IE necessary application? There is a problem in Linux.
« Reply #1 on: March 31, 2005, 05:43:26 PM »

I don't know much about Linux (basically nothing :-) ), but do you use some Windows-emulation software? Because WME is designed to run under Windows, not Linux. In the "The interactive FAQ"-section you will find a description how to run WME-games under Linux using an emulator.

Dionysius

  • Frequent poster
  • ****
  • Karma: 3
  • Offline Offline
  • Gender: Male
  • Posts: 361
    • View Profile
    • On the Tracks of Dinosaurs
Re: Is IE necessary application? There is a problem in Linux.
« Reply #2 on: March 31, 2005, 06:01:23 PM »

Of course, I use Windows-emulators: Wine and Cedega. But I cannot open any project cause I haven't installed IE. May be I need to install Mozilla for Windows?
Logged

Nihil

  • Supporter
  • Addicted to WME forum
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 528
  • Fear me! I'm evil!
    • View Profile
    • Order of Dagon
Re: Is IE necessary application? There is a problem in Linux.
« Reply #3 on: March 31, 2005, 06:16:25 PM »

Sorry, as I said, I don't know much about Linux. But can't you just install the IE there? You can download it for free from the MS-site.

Dionysius

  • Frequent poster
  • ****
  • Karma: 3
  • Offline Offline
  • Gender: Male
  • Posts: 361
    • View Profile
    • On the Tracks of Dinosaurs
Re: Is IE necessary application? There is a problem in Linux.
« Reply #4 on: March 31, 2005, 06:28:10 PM »

Please, give me the link where I can download it. I was in MS site but found nothing :(
Logged

odnorf

  • w00t?
  • Global Moderator
  • Addicted to WME forum
  • *
  • Karma: 7
  • Offline Offline
  • Gender: Male
  • Posts: 1455
  • Lamp dog!
    • View Profile
Re: Is IE necessary application? There is a problem in Linux.
« Reply #5 on: March 31, 2005, 06:35:25 PM »

http://www.microsoft.com/windows/ie/default.mspx

But I suggest to send a pm to MMR. I'm sure he can help you more than we do.
Logged
fl*p

MMR

  • Global Moderator
  • Frequent poster
  • *
  • Karma: 3
  • Offline Offline
  • Gender: Male
  • Posts: 349
  • http://mmrdeveloper.wordpress.com/
    • View Profile
    • TinyWME
Re: Is IE necessary application? There is a problem in Linux.
« Reply #6 on: March 31, 2005, 09:04:09 PM »

As far as I've tested, it's not possible to run the WME tools for creating or editing projects (games).

You can only RUN games under linux, not develop them.

You could run some parts of the tools, but they show wrong (missing bars...)

If you want to develop a game using WME, you should use Microsoft Windows (it's a crap but it's the only solution :( :-\ :'()
Logged

Dionysius

  • Frequent poster
  • ****
  • Karma: 3
  • Offline Offline
  • Gender: Male
  • Posts: 361
    • View Profile
    • On the Tracks of Dinosaurs
Re: Is IE necessary application? There is a problem in Linux.
« Reply #7 on: April 01, 2005, 02:21:59 AM »

Quote
http://www.microsoft.com/windows/ie/default.mspx
There are only updates and service packs and other things for IE. But there is not IE :(.
2 MMR: I think I can create backgrounds and sprites in linux-applications and edit the scripts in any text editor. I need to run compiler correctly only. Please, explain me how to compile wme_demo game in windows that I'll have a single *.exe file.
Logged

joaomesq

  • Teacher / Game Designer
  • Lurker
  • *
  • Karma: 1
  • Offline Offline
  • Gender: Male
  • Posts: 44
    • View Profile
    • Nó Górdio
Re: Is IE necessary application? There is a problem in Linux.
« Reply #8 on: April 01, 2005, 11:02:23 AM »

Black Lizard: You are right. You can indeed make backgrounds in linux and edit script files without using the tools at all. The only question is that Mnemonic didn't release any docs about compiling games without the ProjectMan.

The wme_comp.exe file you are refering to only checks syntax (as far as I know), it doesn't compile. Finally *.dcs in an old script file format. If you change *.dcs to *.script, it works. If you can browse CHM files, check [Setting up a text editor  > Checking the syntax] on the docs for instructions how to use the compiler.
« Last Edit: April 01, 2005, 12:27:12 PM by joaomesq »
Logged
Crisis is just another word for opportunity

Mnemonic

  • WME developer
  • Administrator
  • Addicted to WME forum
  • *
  • Karma: 41
  • Offline Offline
  • Gender: Male
  • Posts: 5683
    • View Profile
    • Dead:Code Site
Re: Is IE necessary application? There is a problem in Linux.
« Reply #9 on: April 01, 2005, 11:42:03 AM »

Black Lizard: You are right. You can indeed make backgrounds in linux and edit script files without using the tools at all. The only question is that Mnemonic didn't release any docs about compiling games without the ProjectMan.
The only way of compiling an entire project is using ProjectMan. The command line compiler only compiles individual scripts and, as you said, it's mainly intended for text editor intergration for checking script syntax.
Logged
Yes, I do have a twitter account
Please don't send me technical questions in private messages, use the forum. ::wave

MMR

  • Global Moderator
  • Frequent poster
  • *
  • Karma: 3
  • Offline Offline
  • Gender: Male
  • Posts: 349
  • http://mmrdeveloper.wordpress.com/
    • View Profile
    • TinyWME
Re: Is IE necessary application? There is a problem in Linux.
« Reply #10 on: April 01, 2005, 01:31:14 PM »

As I've said it's NOT possible to develop wme games under linux 'cause you can't compile them.

Of course you can edit script, background and music. They are standard text/image formats (ASCII text, JPG, PNG...) and the OGG format is port to linux too.

I'm afraid the only solution to develop WME games under a Linux OS is using VMWare or Win4Lin (to run Windows under Linux)
Logged

odnorf

  • w00t?
  • Global Moderator
  • Addicted to WME forum
  • *
  • Karma: 7
  • Offline Offline
  • Gender: Male
  • Posts: 1455
  • Lamp dog!
    • View Profile
Re: Is IE necessary application? There is a problem in Linux.
« Reply #11 on: April 01, 2005, 02:08:00 PM »

Of course you can edit script, background and music. They are standard text/image formats (ASCII text, JPG, PNG...) and the OGG format is port to linux too.

Ogg container + various codecs in it (vorbis, speex and flac) were created with cross-platform in mind. Linux port doens't follow windows port. I'd say it's the other way around  ;)
Logged
fl*p

Dionysius

  • Frequent poster
  • ****
  • Karma: 3
  • Offline Offline
  • Gender: Male
  • Posts: 361
    • View Profile
    • On the Tracks of Dinosaurs
Re: Is IE necessary application? There is a problem in Linux.
« Reply #12 on: April 01, 2005, 04:39:19 PM »

Maybe it will be linux-version of WME in future?
Logged

Dionysius

  • Frequent poster
  • ****
  • Karma: 3
  • Offline Offline
  • Gender: Male
  • Posts: 361
    • View Profile
    • On the Tracks of Dinosaurs
Congratulate me!
« Reply #13 on: April 02, 2005, 12:53:13 PM »

Congratulate me, please! :) I downloaded msdbi.dll from http://down-dll.com/ and installed Mozilla for Windows and then I run ProjectMan in Cedega (not in Wine) and compiled Demo Game from it. And I run this game. I think that I can develop WME games in Linux. Thank you for this Engine. ;)
Logged

odnorf

  • w00t?
  • Global Moderator
  • Addicted to WME forum
  • *
  • Karma: 7
  • Offline Offline
  • Gender: Male
  • Posts: 1455
  • Lamp dog!
    • View Profile
Re: Is IE necessary application? There is a problem in Linux.
« Reply #14 on: April 02, 2005, 01:24:55 PM »

Good news Black Lizard. Did you compile the game as one .exe file or as a seperate package? And are the other tools working or just ProjectMan? Did you try the wme_demo_3d project to see if the hardware accelelation works?
Logged
fl*p
Pages: [1] 2  All
 

Page created in 0.055 seconds with 20 queries.