Please login or register.

Login with username, password and session length
Advanced search  

News:

IRC channel - server: waelisch.de  channel: #wme (read more)

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - Airwaffle

Pages: [1]
1
WME Lite / Building WME Lite
« on: March 22, 2012, 04:17:26 AM »
Em, I don't know if this belongs here, but I'm having some problem building the code for wmelite with Visual Studio 2008 Express for Windows. I followed these instructions http://res.dead-code.org/doku.php/wmelite:building.

First off I get the error: "fatal error RC1015: cannot open include file 'afxres.h'." in wme.rc.
I looked around on the internet a bit, and I tried to solve it by changing it to 'windows.h', since that seemed to work for some people (on different projects though).

Now I get "error PRJ0019: A tool returned an error code from "Performing Post-Build Event..." instead. So yeah, I look at the post-build events,

@copy dep\bass\lib\*.dll $(TargetDir) > nul
@copy dep\sdl\lib\*.dll $(TargetDir) > nul
@copy dep\FreeImage\lib\*.dll $(TargetDir) > nul

Guess I'll just copy them manually and disable the post event. Seems to work.

Then I just get an error message "Some of the essential files are missing. Please reinstall".
Which I track comes from the file PlatformSDL.cpp row 114.

#ifdef __WIN32__
      ::MessageBox(NULL, "Some of the essential files are missing. Please reinstall.", NULL, MB_OK|MB_ICONERROR);
#endif

 I just don't really see where to go from here.

Pages: [1]

Page created in 0.04 seconds with 18 queries.