Please login or register.

Login with username, password and session length
Advanced search  

News:

This forum provides RSS feed. To query recent posts use this url. More...


Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - Derrek3D

Pages: [1] 2
1
Technical forum / Changing Character's Altitude
« on: November 09, 2008, 11:44:39 AM »
Hello,

I'm interested in suggestions on how to implement changing the 3D character's altitude on a scene. I mean things like climbing a ladder, climbing a rope, going up or down the stairs, etc. How can you move the character up without causing it to get smaller (scaled down)? What happens to the character's shadow once he leaves the ground (when climbing a rope for example)?

Thanks.

2
Technical forum / Footprints
« on: May 04, 2008, 10:49:50 AM »
Hi there,

I would like to implement footprints in a scene and I would love to hear opinions on the best way to do that. By footprints I'm referring to some elongated shape that remains on the ground wherever the 3D actor lays its feet. Is a simple image + rotation the best way for a footprint or should the footprint be a 3D object itself?

Thanks.



3
Technical forum / DirectX Version
« on: February 08, 2008, 03:22:13 PM »
Does anyone know what is the proper way to ask Windows if the correct DirectX version is installed (I'm referring to the version that the Direct3D 9 version of WME uses)? It's for a game launcher in C++ that I'm writing to help the user with the DirectX issue.

Also, I'm testing my game on a machine with DirectX 10 installed and my game won't run (it requests D3DX9_34.dll). Will the user need to install DirectX 9 Instead in order to run my game?

Thanks.

4
Technical forum / Sound problem in Theora again...
« on: February 08, 2008, 02:52:37 PM »
Hello,

I have a problem with sound in a Theora video. It's a 720x540 video clip that used to play beautifully in full screen using Game.PlayTheora(). The problems started when I added sound to this video. After adding the sound, the FPS in the engine drop to 1 at the beginning of the video and it becomes extremely choppy. Later on, the FPS goes up to some 200 and the video plays pretty well till the end. Aside from that problem, the audio is never heard at all. The same video (with the sound) plays great in VLC, I should add.

The process I used to add the sound to the video is as follows: I loaded the uncompressed video to VirtualDub, added the audio as Uncompressed PCM and then I used ffmpeg2theora on the resulting video for the final conversion to Theora.

Can anyone tell what am I doing wrong?

Thanks.

5
Technical forum / DirectX and Game Explorer Integration
« on: February 08, 2008, 02:12:04 PM »
Hello,

I have a problem with the installation of my game and I need some help. I'm using Inno Setup to create a setup for my game and I add the following line at the end of my setup script to register the game in Vista's Game Explorer:

Code: [Select]
[Run]
Filename: "{app}\Game.exe"; Parameters: "-gameexplorer add"

The problem is that if I don't have the proper version of DirectX installed on the machine, this line causes WME to display an error regarding the missing DirectX dll. I'm well aware of the DirectX problem and I even prepared a game launcher to help the user install DirectX if it is missing, but the game launcher is designed to run when the user runs the game and not during the installation process.

Is DirectX needed during the Game Explorer registration? If it is not, then why does WME display that error message even if the "-gameexplorer add" parameter is used?

The same goes for the following line:

Code: [Select]
[UninstallRun]
Filename: "{app}\Game.exe"; Parameters: "-gameexplorer remove"

I get the DirectX error message when I uninstall the game if DirectX is not installed.

Thanks.

6
Feature requests, suggestions / Preloading
« on: February 03, 2008, 06:19:39 PM »
After struggling for days with a stuttering scene (see this thread: http://forum.dead-code.org/index.php?topic=2641.0), I now believe that there isn't anything I can do right now to make it work properly so all I can do now is make this request.

What I need is the ability to preload everything to memory and then play everything from memory with no further disk access after the scene finishes loading. I'm talking about images, sprites, cursors, music, sounds, speech, 3D actor attachments, and everything else that might cause disk access during the scene.

Right now there are a few things in particular that break my scene: sounds, speech, 3D actor attachments, and at times, changing the cursor.

Also, right now I can't start particle emitters with many particles in mid-scene because the scene freezes until all particles have been read from disk. A heavy rain emitter with 1000 particles, for example, visibly freezes the scene as it accesses the disk for every single particle.

Anyway, I hope you'll consider this request.

7
Technical forum / Disk Access
« on: January 28, 2008, 01:33:42 PM »
Since I'm having some slowdowns in my game, I ran Process Monitor to see how my game accesses the file system and now that I've checked, I'm not sure how to interpret the results. I'm not sure why, but Process Monitor reports excessive disk access when my scene is running. Sprite images are being loaded over and over again and so are sounds (although I've taken care to use LoadSound() and then PlaySound() with no parameters on all occasions). Particle images are being read non-stop over and over.

Has anyone encounter this issue before? Is the Process Monitor report wrong in some way? Am I doing something wrong in my game that causes this?

My goal is to load everything the scene needs at scene startup and then stop accessing the file system completely for the remainder of the scene.

8
Technical forum / Speech Preload
« on: January 23, 2008, 02:22:27 PM »
Hello,

I have one scene that is very heavy on animation and particles and I take special care in that scene not to load anything from file while this scene is running. Even if I load a small file (e.g.  an ogg sound file), sometimes I can see the particles stutter for a short moment. This is, of course, why the LoadSound(Filename) method exists in the first place but I wanted to ask about speech now. I use Talk() with a string table ID and I would like to add speech sound files in the speech directory to be played automatically by the Talk() method. Will I experience the same slowdown that I experience if I use PlaySound(Filename)? If so, how can I go around this? Will I have to write my own Talk method and use LoadSound(Filename) and PlaySound() to play the speech lines while combining it with the original Talk() method? Is there any preload of speech sound files that I don't know of?

9
Technical forum / Problem with stencil shadows
« on: January 02, 2008, 12:06:14 PM »
I need some help in solving a problem I have with stencil shadows that is somehow hard to explain. In order to simplify the problem imagine a room with a floor and one big shadow-receiving wall. The actor steps near the wall and the shadow is correctly mapped on the floor and on the wall. Up until now everything is ok. Now place a small waist-high shadow-receiving object in front of the wall. Now when the actor steps near the wall, the shadow is mapped on the floor, on the wall (behind the object) and also on the object itself, creating a very unrealistic effect of two shadows with only one light source.

Any idea why this happens and any ways of overcoming the problem?

10
Technical forum / Hidden Geometry and Performance
« on: December 23, 2007, 12:23:22 PM »
In order to improve the way the 3D actor's shadow falls on objects I tried a more complex hidden geometry for one of my scenes and although it really looks better now, I'm experiencing a serious drop in performance. My FPS for that scene dropped from 100 to 70. Is this normal? I read that a more detailed hidden geometry affects its loading time and pathfinding time (if 3D pathfinding is used) but I didn't read anything about performance. On the other hand I read that the hidden geometry is actually rendered so I believe it can have some impact on FPS.

Any info and advice on this issue would be greatly appreciated.

11
Fixed / Animation Events Problem
« on: December 09, 2007, 03:51:53 PM »
I have a problem with my 3D actor's animation events. My event handlers are being called twice: once at the correct frame and the other after the animation ends. Is this a known issue/bug or am I doing something wrong?

My animation is defined like this in my actor's act3d file:

Code: [Select]
ANIMATION
{
    NAME="DoSomething"

    EVENT
    {
        FRAME = 50
        NAME = "DoSomething"
    }
}

And in the actor's script I have a:

Code: [Select]
on "DoSomething"
{
    Game.Msg("DoSomething");
}

The game outputs the "DoSomething" to the screen at the correct frame during the animation and then it outputs it again after the animation ends. Any ideas?

12
Technical forum / Lighting Problem
« on: December 09, 2007, 02:49:17 PM »
I want to be able to illuminate my actor with a very strong light. I placed a strong spotlight in Max, but no matter what I do, the light from that spotlight looks somewhat weak when seen in WME. Has anyone encountered such problem? How can I show the light from a spotlight in its full original intensity? Or more in general, how do I illuminate the actor with a very strong light?

And while we're talking about lighting, what are activity and falloff? I read about them in another thread and I wanted to know what they mean and how to control them in Max/WME?

13
Technical forum / Particles and regions
« on: November 25, 2007, 05:32:11 PM »
Hello,

Can someone please explain how UseRegion works in a particle emitter? How do you set the region that the particles are visible in? If I want to see snow, for instance, through a star-shaped window, and only see the snow inside the star, does UseRegion help me achieve this effect?

And talking about particles, can specific particles look different when entering a certain region? Like maybe receive a color mask when inside the region like the actor can receive when inside a decoration region. Is this possible?

14
Technical forum / Pathfinding
« on: November 25, 2007, 10:22:00 AM »
Hello,

I'm a bit puzzled by the reaction of my 3D actor to clicks around my scene (I use the "Find path using 2D elements only" option). When I click on my "floor" region the actor walks to that point just fine. Now when I click on any non-interactive areas in my scene that are outside the "floor" region, my actor walks to some arbitrary location on the "floor" that apparently has nothing to do with where I made the click.

I have no idea what the problem is but more so, I don't even know what the correct behavior of an actor for when the user clicks on any other non-interactive part of the scene should be. Should the actor walk anywhere in such case?

15
Technical forum / Problem with walking animation
« on: November 25, 2007, 10:20:57 AM »
Hello,

I have a problem with the walking animation of my 3D actor. Every time he starts walking, he starts moving immediately but he does so without the walking animation. Only a bit later the walking animation kicks in. I think the problem is that he starts moving while the engine is making the transition between the idle animation and the walking animation. I tried to shorten the transition time between these two animations and although the "gliding" effect lessened a bit, the transition between the idle state and the walking state is now too abrupt and looks really bad (I mean, that's what the transition is for, after all).

What is the correct way to deal with this situation? Is there a way to cause the actor to start his actual moving only after the walking animation is actually playing and not during the transition?

Pages: [1] 2

Page created in 0.037 seconds with 16 queries.