Please login or register.

Login with username, password and session length
Advanced search  

News:

This forum provides RSS feed. To query recent posts use this url. More...


Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - Amo

Pages: 1 [2] 3
16
Technical forum / Packaging a txt. file
« on: June 21, 2007, 10:15:47 PM »
Hi there,

following thing, we read some txt files out with additional text information for the player, for something like an diary. This runs perfect in debug mode, but when compiling it, it doesn't work and gives out a [null].
Is it not possible to put the txt files in a package? Or do we need a workaround?

17
Technical forum / Memory management problem
« on: January 28, 2007, 10:29:44 PM »
Hi Wintermute folks.

We have following two problems, ok, at least problem is not the right word, desaster seems to be better.

A few test runs of our current version causes following things:
The actual package size is about 500MB, still growing larger and larger. Starting the game, WME loads all the 500MB in RAM!
That is problem enough, but it is going even farther:
Loading a savegame, WME loads the next 500 in RAM, 1GB over all, cause the first 500 ain't getting unloaded.
Loading the savegame again: 1,5GB in RAM, WME crashes, because Windows doesn't want to die...

Ok, any suggestions? I believe, at least I hope, that the error is on our side.
Help, please.

18
Technical forum / The "hold animation"
« on: December 04, 2006, 09:27:49 PM »
Hi there.

Following thing: I created some nice little animations for the 3d actor within the last few days, including a new "hold" animation.
I really like it, smooth arm movement, and so on. The point is: The animation is 56 Frames long (the hold animation).
I know that this is really long, but it looks good, at least in Max. WME is cutting away nearly the complete animation.
Is there any way to prevent WME from doing this? It would really break my heart to lose this work  ;D

Thanks for upcoming hints and answers

19
Technical forum / 3 clicks to shut down - or something that way
« on: September 06, 2006, 04:53:50 PM »
Sorry for the stupid subject, but I do not know how to write it short.

Following problem. With double click you have an immediate scene change. When clicking very fast 3 times doesn't change anything, the normal scene change like with an double click and nothing more. Now the problem:
In one specific scene causes this behaviour a crash. WME log says nothing, the post mortem log the following:

-----------------------------------------------------------------
---------- WME 1.6.001 crash report: 06-09-2006, 17:47 ----------
-----------------------------------------------------------------
wme.exe caused a EXCEPTION_ACCESS_VIOLATION in module wme.exe at 001B:00493677
EAX=00000000  EBX=41C0B63C  ECX=00CA4CD0  EDX=00000010  ESI=00CC8008
EDI=00CC8148  EBP=00000001  ESP=0012F8B4  EIP=00493677  FLG=00010246
CS=001B   DS=0023  SS=0023  ES=0023   FS=003B  GS=0000
Stack trace:
001B:00493677 (0x00000000 0x00000000 0x00000000 0x00000000) wme.exe

Thanks for upcoming help
Amo

20
Technical forum / Crossfading vs. volume
« on: September 01, 2006, 04:55:04 PM »
Hi there.
We want to crossfade from one ambient to another, unfortunately the second one has to be set to a volume of 40%.
WME does the fading fine, but kicks the 40% and sets the volume to 100%.
Are there any solutions to solve that?

21
Technical forum / A package question
« on: August 31, 2006, 02:29:23 PM »
Hi there!

We actually played a bit around with the real good working package system of WME.
During this some questions came up and we do not want to start an time intensive trial and error.
Especially, when Mnemonic surely knows the answer.

Ok, when dividing the project into several packages, are there any folders and datas which should be better not excluded from the data folder and copied into another packages? Are there folders which must be together in one package?

Thanks for upcoming posts.

22
Technical forum / Problem with enable lights
« on: August 30, 2006, 08:31:38 PM »
Hi there. We searched a bit around and found in thread http://forum.dead-code.org/index.php?topic=824.0 some code about a traffic light.
We adapted the code, or better said, reduced it, that it fits our purpose. Ok, we hoped that.
Point is. We want to deactivate the 3dgeometry lights, because it looks scrappy, when the light in the scene gets switched off, but the actor gets still influenced. Our code looks that way:

Code: [Select]
Scene.DisableLight("Spot_01");

But it doesn't affect the light source "Spot_01" in any way. We created the spot in 3ds Max in connection with the geometry.
Where is our error?

Thank you for upcoming posts.

23
Technical forum / Problem with blocking areas
« on: August 23, 2006, 07:48:44 PM »
Hi there,
next question. In some scenes the no go areas work good. We had to combine the 3d geometry with the 2d blocking areas. That works normally fine, but sometimes the 3d actor walks trough the blocks without any notice. The other thing happens, that the actor stopped at the block, but after clicking two or three times he walks through. Is that a known mistake on our side, or a bug in WME?

Edit:

In scrolling scenes it is impossible for us to solve the problem...
Any hints we missed?

24
Technical forum / A more elegant way to make a nice sky
« on: August 23, 2006, 05:29:20 PM »
Hi there we created a little script to create a moving sky. Unfortunately it was a bit to fast, so we slowed our sky down.
The result is that it is slower now, but it lags, when decreasing the sleep value lesser than 100.

/////////////////////////////////// Himmel ///////////////////////////////////////////
var SomeEntity;
SomeEntity  = Scene.GetNode("himmel");
SomeEntity.SkipTo(-256,-3);

Game.Msg(SomeEntity.Visible);
while (true)
{var himmel;
   for(var i=-256; i < 256; i=i+1)
   {
      SomeEntity.SkipTo(i,-3);
      Sleep(100);
      if( i == 256) { i = -256;}
   }
}

Is there a more elegant way to solve that?

Thanks for upcoming help.

25
Technical forum / Characteroptimizing and the polycounter
« on: August 23, 2006, 10:22:29 AM »
Good morning!

I made several 3d Actor tests during the last days and recognized, that the poly counter tells my something total different to what Max says.
My Actor in Max has 2088 Triangles but WMEs poly counter shows about 4600 in an nearly empty test scene and about 6500 (!) after opening the Escape Menu (just some little textured windows with standard buttons save, exit, etc. )
How is that comming? Or better asked, how can I optimize that? After loading the actor twice one as NPC one as player I lost about 30 fps (from 85 to 53) I better do not think about whats happening after loading a second NPC.
My workstation is really not slow (P4 3Ghz, GeForce 6600GT, 1Gbyte RAM), but we can't expect that possible users accept that high system specs for a 2.75D adventure.
What is the polycounter really counting? I can't find where the triangles should be.

26
Technical forum / Get name of an window
« on: August 22, 2006, 10:05:46 AM »
Hi there. As written in the script reference we can get the name of a scene with scene.name.
Is there an eqal way to get the name of a window? name.window doesn't work.

Thanks for help

27
Technical forum / Including functions.
« on: August 20, 2006, 03:25:27 PM »
Hi there. We used during the last two days the "#include "scripts\scriptname.inc" " and it works fine for the purposes we needed it, but then we got a problem. When writing an function in an *.inc it will not work. We could need it really, or a better way to do. The thinking behind this was, to write functions we would need in many scenes, in an separate *.inc script and load it at the position we need via #include "scripts\scriptname.inc"

Thanks for help.

28
Technical forum / Game.activity = false is not enough
« on: August 19, 2006, 05:16:33 PM »
Hi there, we set the game activity to false during monologues. That works actually in that way, that the cursor changes and the player cannot set any new target position, but that is not enough, because the user can still click around, abort the monologue and do what he wants. How can we set the game to a "full inactivity" I mean, no cursor, no keyboard entries, like an ingame cutscene?

Thanks for upcoming replies

29
Technical forum / Next cursor problem
« on: August 18, 2006, 09:11:00 PM »
Good evening. We are still working on our cursors and fortunately could solve many problems with the great help from this forum.
In this thread you can read the other thing about our cursors.
http://forum.dead-code.org/index.php?topic=1670.0

This maybe could help to understand the problem better.
We have several cursor sets now, one for normal background walking, one for entities, one for walking with tool in the hand, one for entities and tool in the hand, but now we need another set
for 3d characters, when hovering over them. We need this to open an talk or inventory function when left clicking on an NPC or on our player. Can somebody please help us out? We have actually no idea how to solve that.

As mentioned at the top, I am impressed about the great help here, you are the reason why we could get that far in that short time, with a new scripting language.

30
Technical forum / Query an 3d actors position
« on: August 18, 2006, 05:04:49 PM »
The title says it all I guess. How to?

Pages: 1 [2] 3

Page created in 0.034 seconds with 17 queries.