Please login or register.

Login with username, password and session length
Advanced search  

News:

For WME related articles and tutorials visit WME Resource Center.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - Guardian

Pages: [1]
1
Done / Re: Sprite flip
« on: April 21, 2006, 06:32:15 AM »
Thank you.

2
Done / Re: Sprite flip
« on: April 20, 2006, 09:37:41 AM »
2 Mnemonic:
Is there benefit if I shall use pow. of 2 sized textures for my entities. Any speedup? Or subframes are splited in compile-time?

3
Technical forum / Re: Scrolling speed bug
« on: April 20, 2006, 07:48:07 AM »
It seems I can't.  :(
Thanks.

4
Technical forum / Re: Scrolling speed bug
« on: April 20, 2006, 06:21:01 AM »
Ok, again, I've change this values. :) And again - there is different speed in a window mode and in a fullscreen mode. This is not right thing. For example how can I make scene which looks equal in all modes(scene must be 3 screen long at least)?

5
Technical forum / Re: Scrolling speed bug
« on: April 19, 2006, 11:30:46 AM »
Yes, of couse. I know it.

But still is it ok when one scene scroll different in different window modes?
Actor moving is looks like similar in each modes (or may be a little). But background is not.
I can guess that engine scrolls background layers improperly, this moving is not based on time delta.

6
Technical forum / Scrolling speed bug
« on: April 19, 2006, 08:47:32 AM »
Why scrolling speed is different when I run game in window and fullscreen(scene is 3 screen long)?
In window actor run in center and background, whenever in fullscreen mode - actor have time to came up to window side. Is it a bug?

7
Done / Re: Particles system
« on: April 18, 2006, 11:08:10 AM »
Particle system is in engine now. Nice improvement. Tribute to Mnemonic :)

8
Technical forum / Re: Script runs slowly when VSYNC is on
« on: April 18, 2006, 09:45:08 AM »
Well, I can explain what I do:
I'm just create new project with usual template in ProjectMan. There is nothing added to default script. And I put on scene two layers - one sky (800x600, with one sprite also 800x600), another layer foreground (2400x600, with smaller sprites - 3 of 800x600). ok, this sprites isn't optimized, but this is just a test. On PC with GeForce5900XT when player go scrolling speed is one. On another PC with integrated video card - Intel865 another. This isn't good. With VSync off frame rate is 8 time higher, and even mouse smoothly moves on each PCs and animation of "molly" is better looks. So that do you think about it? There is no GPU limit, just scripts lag and of couse VSync.
I just want to say that you main loop suggested above isn't be right for situation when VSync is on.

9
Done / Re: Sprite flip
« on: April 18, 2006, 09:25:46 AM »
Well, get&put pixel operations is quite good. I just want to do this more quickly. Thanks for answering.

10
Done / Re: Sprite flip
« on: April 18, 2006, 08:13:23 AM »
Ok, thanks for answer, may be you could make another thing - give to plug-in makers interface to sprite(read-only, like device interface in the game object)? Is it possible?
 Thanks anyway.

11
Done / Sprite flip
« on: April 17, 2006, 02:27:55 PM »
Does WME support HW flipping of sprites? (I mean mirroring)
May be in next release it will be?

12
Technical forum / Re: Script runs slowly when VSYNC is on
« on: April 17, 2006, 02:18:54 PM »
Hi
This method, described above is preferred of course.
But there is one thing - currently  VSync cannot be change by user in WME. Change it in video driver settings is not good idea, isn't it?
And even with you method script run slowly sometimes. (With LCD monitors - refresh rate 75Hz max - very slow!)
It will be easy to add property to Game object called VSync, I think. There is nothing special, just one of presentation parameters on Direct3DDevice creation.
This is very important for us. We want to produce commercial game on you engine.

With best regards.

13
Technical forum / Re: Alpha channel question
« on: April 14, 2006, 12:50:25 PM »
Ok, thanks, problem is solved, using TGA's with transparent background.

14
Technical forum / Alpha channel question
« on: April 14, 2006, 10:42:03 AM »
We try to use TGA sprites with alpha channel, and get this picture:
http://www.gamedev.ru/images/?id=10922  (40kb)

In this scene there are 3 sprites - sky(bmp), sun(TGA with 8bit alpha) and clouds(TGA with 8bit alpha)
Demo is running with HW acceleration check.
Is it bug? Or may be WME does not support 8bit alpha?

15
Done / Particles system
« on: April 13, 2006, 01:56:34 PM »

In game that I making now with your engine I need some particle system stuff. Ok, particles are sprites actually, but I can find any blending operation with it in WME (except alpha blending and opacity witch is not enough for my purposes). I'm interested in color addition, subtraction, multiplication with two or more sprites. Especially with fully scriptable parameters.
Is WME support this feature now? Or may be in future releases? I've looked in documentation but found nothing. Also I've seen one post in forum with similar question, but it has no answers.
Any help is appreciated

Pages: [1]

Page created in 0.031 seconds with 18 queries.