Please login or register.

Login with username, password and session length
Advanced search  

News:

Forum rules - please read before posting, it can save you a lot of time.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - binary1

Pages: 1 2 3 [4]
46
Technical forum / Re: 3D actor not loading
« on: February 28, 2012, 10:12:01 PM »
I don't see the geometry at all.  If I try and place an actor, all I see is the actor's label on part of the image.  I think the camera must be wrong.  I'm going to try again to mimic the setup of the demo when I get home from work.

47
Technical forum / Re: 3D actor not loading
« on: February 28, 2012, 04:07:29 PM »
Progress: I had scene geometry set to display in the scene script so it showed when I ran the game. I didn't realize that you could set that in the scene editor also.  The box was covered by the Entity properties box.  After setting the editor to display geometry, I found that the scene geometries I created from 3D models don't work but the ones I base on the geometry.3ds file from the demo are ok.  Someone else had a similar problem (hidden geometry).  One of the things suggested was to reverse the walk plane.  I did that without success.  I've also seen that people have had to change the camera angle slightly when exporting from Cinema 3d but I think I have a bigger problem than that.  I'm currently starting with the demo geometry.3ds file and working backwards.  Any other suggestions would be appreciated.

48
Technical forum / Re: 3D actor not loading
« on: February 27, 2012, 03:11:59 AM »
After "tweaking" the geometry.3ds file, Trinity disappeared again.  I can place Trinity only in the scene I made using the files for the Front scene.  I've spent the time since I posted last trying to get things to work without success.  I tried creating a simple scene in cinema 4d and exported the .3ds geometry file.  When I try to place Trinity, all I see is Trinity's name on half of the background.  I was hoping to create the geometry for backgrounds that I have (similar to what Anarchist was describing) but I've tried with both backgrounds and models without success.  I suspect I'm exported the Cinema 4d model incorrectly.  Molly works but Trinity is invisible.  Any suggestions? 

49
Technical forum / Re: 3D actor not loading
« on: February 25, 2012, 06:06:59 PM »
Thanks.  I read through the documentation and then, went through the 2D tutorials before starting with 3D.  I was walking through the documentation but forgot about the 3D tab.  I was thinking that naming the geometry file "geometry.3ds" made the association.  I fixed the link in the 3D tab.  Everything is working now except that I have some tweaking to do with the geometry file to stop Trinity from walking on the wall!  Thanks for the fast response.

50
Technical forum / Re: 3D actor not loading
« on: February 25, 2012, 04:37:38 PM »
Thanks for the fast response.  It was after midnight for me but I'm back at it now. 
I previously tried changing the scale of the actor but that didn't help.  I'll try turning the plane around.  I also tried putting the actor in while in SceneEdit.  I could place the actor easily in the "Front" scene that was just copied from the 3d demo.  I lose the mouse cursor and never see the actor in the other two scenes.  One of the scenes uses the geometry and backgrounds from the 3d demo so I don't think it is a scale problem in that one.  I'm going to try again with a completely new project.  Is there something to look for in any of the scripts?

51
Technical forum / 3D actor not loading
« on: February 25, 2012, 09:47:21 AM »
There is probably a simple solution but I'm stumped.  I'm just learning how to use 3D models with the engine.  I've looked through the documentation and played with the 3d demo.  I created a new scene using the demo as a model.  I made the geometry file in Cinema 4d and exported it as .3ds.  Everything looked ok but the actor didn't load.  Next, I tried adding the Front scene to the project.  The actor loads fine in that scene.  Then, I tried adding another scene using the files from the demo.  As far as I can tell, all the nodes are the same as the demo.  I used the 3d demo's geometry files in addition to all the other files.  But the actor doesn't load.  All three scenes are in the same project.  The game script is loading the actor (actor = Game.LoadActor3D("actors\trinity\trinity.act3d");) and I've tried different locations to use for placing the actor in the scene script.  I can add Molly without any problem.  Does anyone have any idea what I might be doing wrong?  Thanks.

Pages: 1 2 3 [4]

Page created in 0.108 seconds with 20 queries.