Please login or register.

Login with username, password and session length
Advanced search  

News:

IRC channel - server: waelisch.de  channel: #wme (read more)

Author Topic: Scrolling speed bug  (Read 3730 times)

0 Members and 1 Guest are viewing this topic.

Guardian

  • Lurker
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 15
    • View Profile
Scrolling speed bug
« on: April 19, 2006, 08:47:32 AM »

Why scrolling speed is different when I run game in window and fullscreen(scene is 3 screen long)?
In window actor run in center and background, whenever in fullscreen mode - actor have time to came up to window side. Is it a bug?
Logged

Mnemonic

  • WME developer
  • Administrator
  • Addicted to WME forum
  • *
  • Karma: 41
  • Offline Offline
  • Gender: Male
  • Posts: 5683
    • View Profile
    • Dead:Code Site
Re: Scrolling speed bug
« Reply #1 on: April 19, 2006, 10:41:13 AM »

To quote myself from the other thread:

As for the scrolling speed, you can adjust it using the Scene properties (ScrollSpeedX, ScrollSpeedY, ScrollPixelsX, ScrollPixelsY). The default values are probably set too low, so the scrolling sometimes doesn't catch up when the framerate is low.
Logged
Yes, I do have a twitter account
Please don't send me technical questions in private messages, use the forum. ::wave

Guardian

  • Lurker
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 15
    • View Profile
Re: Scrolling speed bug
« Reply #2 on: April 19, 2006, 11:30:46 AM »

Yes, of couse. I know it.

But still is it ok when one scene scroll different in different window modes?
Actor moving is looks like similar in each modes (or may be a little). But background is not.
I can guess that engine scrolls background layers improperly, this moving is not based on time delta.
Logged

Mnemonic

  • WME developer
  • Administrator
  • Addicted to WME forum
  • *
  • Karma: 41
  • Offline Offline
  • Gender: Male
  • Posts: 5683
    • View Profile
    • Dead:Code Site
Re: Scrolling speed bug
« Reply #3 on: April 19, 2006, 05:00:11 PM »

As I said, the default values are a little unfortunate. The scene is set to scroll by one pixel every 10 milliseconds, which means the game would have to run at 100FPS (1000/10) to get the desired effect. Settings like this should overcome the issue:
Scene.ScrollSpeedX = 20;
Scene.ScrollPixelsX = 2;
Logged
Yes, I do have a twitter account
Please don't send me technical questions in private messages, use the forum. ::wave

Guardian

  • Lurker
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 15
    • View Profile
Re: Scrolling speed bug
« Reply #4 on: April 20, 2006, 06:21:01 AM »

Ok, again, I've change this values. :) And again - there is different speed in a window mode and in a fullscreen mode. This is not right thing. For example how can I make scene which looks equal in all modes(scene must be 3 screen long at least)?
Logged

Mnemonic

  • WME developer
  • Administrator
  • Addicted to WME forum
  • *
  • Karma: 41
  • Offline Offline
  • Gender: Male
  • Posts: 5683
    • View Profile
    • Dead:Code Site
Re: Scrolling speed bug
« Reply #5 on: April 20, 2006, 07:43:02 AM »

a) increase the values to find the ones that suit you
b) if it's not enough for you, you can't
Logged
Yes, I do have a twitter account
Please don't send me technical questions in private messages, use the forum. ::wave

Guardian

  • Lurker
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 15
    • View Profile
Re: Scrolling speed bug
« Reply #6 on: April 20, 2006, 07:48:07 AM »

It seems I can't.  :(
Thanks.
Logged
 

Page created in 0.023 seconds with 20 queries.