Please login or register.

Login with username, password and session length
Advanced search  

News:

IRC channel - server: waelisch.de  channel: #wme (read more)

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - Adventure Bird

Pages: [1]
1
Technical forum / Using Script method from a entity handler script
« on: August 16, 2010, 09:22:40 PM »
I have 2 problems or maybe I should better say "questions".

The first question is, how can I insert a entity to scene after a specific entitiy/node on the layer. I only found an add method and a insert method by integer. But no "IndexOf" node method which I would need if I want to insert the entity on the correct order.

The second thing is. I don't know exacly how I should handle following:



I have a scene with a background entity. In the scene_init.scipt I wrote a method RepaintContainerCity() and an 3D array for the container places. The method creates a lot of entities for the container objects. To each object will be added a script which takes the eventhandler for talk/take/look. But in this script I haven't access to the repaint method. For example: I want to click on a container --> take container --> container handler should call the method of scene_init.script repaint

2
Technical forum / Re: 3D Array
« on: August 13, 2010, 10:38:28 PM »
Thanks a lot.

3
Technical forum / 3D Array
« on: August 13, 2010, 04:57:38 PM »
It's long time ago since I used my last 3D array that uses normal arrays.

Maybe somebody could help me.
Here is the code:
Code: [Select]

var Spielfeld;
function initSpielfeld()
{
Spielfeld = new Array(15);
for ( var x = 1; x <= 15; x=x+1)
{
Spielfeld[x] = new Array(12);
for( var y = 1; y <= 3; y=y+1 )
{
Spielfeld[x][y] = new Array(3); // HERE is the problem with the two brackets
for (var z = 1; z <= 12; z=z+1 )
{
Spielfeld[x][y][z] = 0;
}
}
}
}

4
Technical forum / Re: Subtitles Problem
« on: August 09, 2010, 06:00:40 PM »
Hmmm, I found the failure and I'm not sure why this happens.

I had a bad animation in the actor file. But I don't know why it react this way.
I just deleted the animation sprite paths in the talk animation. There are no runtime errors and all works fine but text is not showed.
If i put the paths into script again it works.

Code: [Select]
ANIMATION
  {
    NAME       = "talk"
   
    // nothing
  }

don't show text

and this works
Code: [Select]
ANIMATION
  {
    NAME       = "talk"
   
    LEFT       = "actors\Frau\Stehen.sprite"
    RIGHT      = "actors\Frau\Stehen.sprite"
    UP         = "actors\Frau\Stehen.sprite"
    DOWN       = "actors\Frau\Stehen.sprite"

    UP_LEFT    = "actors\Frau\Stehen.sprite"
    UP_RIGHT   = "actors\Frau\Stehen.sprite"
    DOWN_LEFT  = "actors\Frau\Stehen.sprite"
    DOWN_RIGHT = "actors\Frau\Stehen.sprite"
  }

5
Technical forum / Re: Subtitles Problem
« on: August 09, 2010, 05:17:49 PM »
The subtitle of the actor "frau" isn't showed. And it seems that the problem are not the position attributes because the attributes have the same values as the other actors.

6
Technical forum / Subtitles Problem
« on: August 08, 2010, 12:54:40 PM »
I have a problem with one actor. The subtitles of this actor aren't shown at the bottom of the screen. Usually there are two actors in the scene and for the first actor it works fine. Additionally I tried to load an additional actor to the scene and let him talk. Works fine, too. Because of that, I guess something is wrong with my actor. But the settings are the same.

Here the upper part of actor files:
Code: [Select]
ACTOR
{
  NAME = "Mann"
  CAPTION=""
  SCALABLE = TRUE
  INTERACTIVE = FALSE
  X = 400
  Y = 460
  SCRIPT="actors\Mann\Mann.script"

  FONT = "fonts\verdana_red.font"
...
}

NAME = "Frau"
  CAPTION="Frau"
  SCALABLE = TRUE
  INTERACTIVE = TRUE
  X = 600
  Y = 660
  SCRIPT="actors\Frau\Frau.script"
 
  FONT = "fonts\verdana_red.font"
 ...
}

I overrode the talk methode that a picture appears and behind the text appears a black box/picture.
Here the code of "Frau" script:

Code: [Select]
method initFrau(Frau)
{
Frau.SubtitlesPosRelative = false;
Frau.SubtitlesPosXCenter = true;
Frau.SubtitlesPosX = 512;
Frau.SubtitlesPosY = 720;
Frau.SubtitlesWidth = Game.ScreenWidth - 40;

}
method TalkAnimation(Text, EntityPfad)
{


    Game.Interactive = false;
    //initFrau(this);
var vordergrundLayer = Scene.GetLayer("Vordergrund");
    vordergrundLayer.AddEntity("faceEntity");
vordergrundLayer.AddEntity("sprechBox");
    var entityObject = vordergrundLayer.GetNode("faceEntity");
var entitySprechbox = vordergrundLayer.GetNode("sprechBox");
   
entitySprechbox.SetSprite("\sprites\system\sprechBox.sprite");
entitySprechbox.Interactive = false;
entitySprechbox.X = 0;
entitySprechbox.Y = 706;
entitySprechbox.active = true;

    entityObject.SetSprite(EntityPfad);
    entityObject.Interactive = false;
    entityObject.X = 876;
    entityObject.Y = 706;
    entityObject.Active = true;

    this.Talk(Text);
    vordergrundLayer.DeleteNode(entityObject);
vordergrundLayer.DeleteNode(entitySprechbox);
    Game.Interactive = true;
}

The scene init script:
Code: [Select]
if(!StateTerasse_Ballon.Visited)
{
  StateTerasse_Ballon.Visited = true;
 
  var Tuer = Scene.GetNode("Tuer");
 
  Tuer.SetSprite("scenes\Terasse_Ballon\Tuer_oeffnen.sprite");
  Sleep(2000);
  Tuer.SetSprite("scenes\Terasse_Ballon\Tuer_offen.sprite");
  //var FrauActor = Scene.LoadActor("actors\Frau\Frau.actor");
  var FrauActor = secondActor;
  FrauActor.Active = true;
  FrauActor.SkipTo(300, 520);
  FrauActor.GoTo(450, 520);


  var ServiceActor = Scene.LoadActor("actors\Frau\Frau.actor");
  ServiceActor.Active = true;
  ServiceActor.SkipTo(400, 520);
  ServiceActor.Talk("Hallo Wie gehts.");

  FrauActor.Talk("Was geht den jetzt ab, wo ist mein Text? Den suche ich und finde Ihn nicht!");
  actor.SkipTo(300, 520);
  actor.GoTo(500, 520);
  actor.TalkAnimation("Sie sind uns Dicht auf den Versen.", "sprites\faces\normal.sprite");
  actor.TalkAnimation("Wo geht es weiter?", "sprites\faces\normal.sprite");
 
  FrauActor.TalkAnimation("Wir müssen die Tür blockieren, ich halte Sie zu, suchen Sie was zum Verriegeln. ", "sprites\faces\Frau_normal.sprite");
  //Tuer.Visible = false;
  var LayerMain = Scene.GetLayer("main");
  LayerMain.DeleteNode(Tuer);
  //Tuer.SetSprite("scenes\Terasse_Ballon\Tuer_geschlossen.sprite");
  //Scene.DeleteEntity(Tuer);
  var Tuer2 = Scene.GetNode("Tuer2");
  Tuer2.SetSprite("scenes\Terasse_Ballon\Tuer_schliessen.sprite");
  Sleep(2000);
  LayerMain.DeleteNode(Tuer2);
  //Tuer2.SetSprite("scenes\Terasse_Ballon\Tuer_geschlossen.sprite");
  Scene.FadeOut();
  //Scene.DeleteEntity(Tuer2);
  FrauActor.Active = false;
  Scene.UnloadObject(FrauActor);
  var BlockierendeFrau = Scene.GetNode("Frau");
  BlockierendeFrau.SetSprite("scenes\Terasse_Ballon\Frau_blockieren.sprite");
  Scene.FadeIn();
  // this is our first visit in this scene...
}

What is all necessary for showing text of an actor and is not depending on all actors?
Perheps someone find a failure in my code.
Thanks

7
Not a bug / System Crash Win7
« on: November 21, 2009, 07:25:19 PM »
Hello, I changed to Windows7-64bit and after installation there was a new update to 8.0.11.
Whenever I try to run/debug a game the computer freeze in a blackscreen. No reaction, only solution is to push the button.

What's the problem, 64bit or the new OS?
New version?


8
I found the game_loop function and could change font and position of WinCaption. This seems the best way.

9
I read some posts about setting the text from actor or entities.

To set the actor text position one time isn't very difficult, but must I set this for each entity?

Is there a very simple way to set the text position at one place for all entities?

10
Technical forum / Re: Existing entity on layer
« on: August 26, 2009, 07:56:55 PM »
Thank I use the way be add dynamic entities now.

11
Technical forum / Existing entity on layer
« on: August 25, 2009, 11:20:50 PM »
I want to display some prepared entities on the top layer of the scene. In the sdk I found just a method to create new entity on a layer. (add/insert)

Is it possible to load an entity like that: Scene.LoadEntity(). // Into which layer will entity be loaded, always main layer?


12
Technical forum / Re: Sound Problem
« on: August 03, 2009, 07:04:48 PM »
Thank's a lot. I found the problem. It's a shame, but it had to do with my soundblaster configuration. I use a 7.1 Surround system, output from game was sent to the left and right speaker, but both of them was configured to a special mode. So all output get lost. Now it's working perfectly.


13
Technical forum / Sound Problem
« on: August 02, 2009, 09:02:54 PM »
Hello

I have a problem with playing sounds. I'm using WME(1.8.1) first time, probably it's something simple.
I tried to play a audio file (ogg/wav) but if I run the project: nothing happens. The IsMusicPlaying() function shows that the music is running. Volume is on 100%. No sprites kill sound and nothing muted.

I tried to open the demo project 2d, but there is also the same problem.
The sound in demo 3d project is running nicely. Other completed game projects like "Dirty Split" are ok, too.
In Project Manager sounds in preview modus are working fine, too.

I'm working on Vista 32bit, Sound Blaster X-Fi.

If I run a project, windows sound mixer volume for the application is set to 0 volume. But if i set the value higher there is also no effect.

Sorry for bad english and best regards from switzerland

Pages: [1]

Page created in 0.299 seconds with 23 queries.