Please login or register.

Login with username, password and session length
Advanced search  

News:

IRC channel - server: waelisch.de  channel: #wme (read more)

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - 2.0

Pages: [1] 2
1
Technical forum / Multitouch in WME/WME Lite - is it possible?
« on: November 01, 2013, 05:09:27 PM »
Hi!

Interests in possibility of the multi-touch (at least for two fingers) in the WME. If it is possible - where exactly in sources it is necessary to do additional implementation?

2
Obecné fórum / Waldemar Matuska song :)
« on: August 06, 2013, 07:40:16 AM »
Hi guyz!

I think it is appropriate to ask this question in this thread :)
Interests the song which sings W.Matuska in the Fantom Morrisvillu movie.
http://www.youtube.com/watch?v=80VJuxTJLNw
Whether there is somewhere this song in a MP3 format, without inserts from the movie?
Thanks!

3
General Discussion / Issues at dead-code.org site
« on: June 25, 2013, 04:48:09 PM »
Hi Mnemonic!

It's strange, but the main site (not forum) have many issues in encoding / page formatting. It concerns to all language versions other than English.
Do you know about that? Or is it part of some global plan? :)

4
WME Lite / Mac OS compilation
« on: May 25, 2013, 11:18:08 AM »
Hi Mnemonic!

Thanks for the update of MacOS/iOS sources and dependencies!
But have some misunderstanding of compiling project for Mac OS. When I click to Run, compilation starts, proceeds, ends (data.dcp lays in Resources). And no more. I've received a message that build completed, but have no running application, and can't find builded one. What I need to do to run/obtain working application?
Issue solved, caused by wrong dcp :)

5
WME Lite / Dependences for Mac OS?
« on: April 24, 2013, 07:40:44 PM »
Hi Mnemonic!

Whether there is an opportunity to update dependences for Mac OS - with later SDL version, etc?

6
WME Lite / Glitches in scripts
« on: December 29, 2012, 03:30:35 AM »
Hi!

Have some bugs at iPad. For example running this code in one script crushes the device.
Code: WME Script
  1. for (var t=0; t<=1; t=t+0.02)
  2. {
  3.         Twin.X = ToInt(Math.Pow((1-t),2)*this.X + 2*t*(1-t)*O1.X + t*t*P2.X);
  4.         Twin.Y = ToInt(Math.Pow((1-t),2)*this.Y + 2*t*(1-t)*O1.Y + t*t*P2.Y);
  5.        
  6.         if (t<0.6) d = d*1.025;
  7.         else d = d*1.05;
  8.                        
  9.         Sleep(20);
  10. }

All variables are initialized.
In other script this kind of code works properly.
In device emulator, and in lite and full versions of WME on PC all works correctly too.
What it can be?

7
WME Lite / Error running project on Xcode (iPad Simulator)
« on: August 31, 2012, 12:59:35 PM »
Hi there!

When I've run my project on iPad simulator, next log is arriving:

Quote
15:53:17: Scanning packages...
15:53:17:   Registered 2529 files in 1 package(s)
15:53:17: Initializing scripting engine...
15:53:17:   Script compiler is NOT available
15:53:17: Error opening file 'startup.settings'
15:53:17: CBGame::LoadSettings failed for file 'startup.settings'
15:53:17: Error loading game settings.
15:53:17:
15:53:17: Shutting down...
15:53:17: Shutting down scripting engine

data.dcp from original projects (demo touch from WME Lite or simply demo from WME) runs perfectly.
I've changed my startup.settings to file from wme lite - no result.
What it can be?

Thanks.

8
Bug reports / Mega bug with rotation
« on: June 21, 2012, 11:02:23 PM »
Hello!

When I rotate the entity (for example, clock hand) with, for example

Code: WME Script
  1. on "LeftClick"
  2. {
  3.     this.Rotate = this.Rotate + SomeValue;
  4. }
  5.  

the visible image of the entiny is rotates, but the "logical" image is not rotated! I.e a can't click the image of the entity to rotate it again. It's necessary to click on that place where the object was initially.
So I have a question - in what place of sourses there was this detachment into two images - visible and logical?.



9
Technical forum / String tables bug?
« on: April 20, 2012, 02:09:37 PM »
Hello!

The bug(?) is next.

In the string.tab file I have a string

Code: [Select]
SYSENG0200 Some text
When I insert "\syseng0200\" (without quotes) at the Text field of the some static control, it works fine. Dispaying text is "Some text".
When I use a script, that makes something like

Code: [Select]
someStaticControl.Text = "\syseng0200\";
Displaying text is "\syseng0200\".

What wrong do I do?

10
WME Lite / Unsupported features
« on: May 21, 2011, 11:23:13 AM »
Hi Mnemonic!

You've done a great work, thanks. But I have a question.

Is this features:
- Sprite frame mirroring.
- Sprite rotations.
will work in future releases of WME Lite?

Regards.

11
Technical forum / Speed of saving
« on: November 08, 2010, 11:08:57 PM »
Hi there,

Is it possible to improve the saving speed in the WME engine? Now the saving occurs something about few seconds, but maybe is it real to make this action much more faster?

Thanks

12
Technical forum / Questions about animated cursor and selected item
« on: July 17, 2010, 01:34:26 AM »
Hi All!

When I try to use animated sprite with the Game.SetCursor() function, the animation is not works, cursor is displayed only the first frame of animation (in SpriteEdit all ok, loop working etc). Why? Or animated cursor is not supported in wme?

Second question is about selected item. When I choose the item in inventory, item is attaching to the cursor and disappearing from the inventory. I can move this object by cursor moving, but... but i need to operate this attached object by the script. For example I need to make it invisible for a some time or after the right click I need this object to fly to the inventory fluently instead of instant transfer by default (by Game.SelectedItem == null). But I cant get access to the attached object - I dont know what is it (this object is not equal to the inventory item as I understand). And question is - is it possible to move (rotate, scale, etc) attached object as I want?

PS. Don't shoot for my bad English, I'm talking as I can :)

13
Technical forum / Entity container question.
« on: December 09, 2009, 05:08:44 AM »
Hi there.

Making a built-in particle editor for the game I was confronted with such difficulty.
Entity container, which I created in PE-window, has an Entity that hooked Particle Emitter.
When I try to represent Particle Emitter's area (x, y, width, height) by the scaling Entity (entitie's sprite - semi-transparent 1x1 pix, ScaleX = width, ScaleY = height), I have no result.
Is it mean that entities in Entity Container has not working parameters (Scale etc) such as window's controllers (Static etc)?

Thanks.

14
Feature requests, suggestions / Some additional functionality needed
« on: December 03, 2009, 12:44:27 AM »
1. Float type for X,Y,Rotate,Scale etc of Entities and other objects.
It needs for more smoothable moving (without discrete jumping from pixel to pixel) of this objects at the screen.

2. Possibility to configure Node's z-order at the layer from the game. Also possibility to configure z-order relatively to particle emitter.

3. Working entities width & height :)

4. Possibility to detect Entity's Layer-owner.

Not so much, isn't it?  ;D

15
Техниче�?кий фор�?м / Кто-ниб
« on: November 25, 2009, 03:37:43 AM »
Привет в

Pages: [1] 2

Page created in 0.041 seconds with 22 queries.