Please login or register.

Login with username, password and session length
Advanced search  

News:

IRC channel - server: waelisch.de  channel: #wme (read more)

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - Azrael

Pages: [1]
1
WME Lite / Errors compiling for ipad
« on: October 19, 2011, 03:28:30 PM »
Hi,
I've created a test project for ipad, it works well with the Ipad Simulator but when i try to test it on a real device it doesn't compile.

The first error is:
"[BEROR]No architectures to compile for [ARCHS=armv7, VALID_ARCHS=armv6, i386]"

Then i go to the "Build Settings" and add "armv7" to the "Valid Architectures". It was "armv6 i386" now it's "armv7 armv6 i386".

But now i have a new error:
"Ld /Users/azrael/Library/Developer/Xcode/DerivedData/wmelite-aregolaikwmsxtaipuhimuunwblh/Build/Products/Debug-iphoneos/wmelite.app/wmelite normal armv7
    cd /Users/azrael/Desktop/asd/wmelite/xcode-ios/wmelite
    setenv IPHONEOS_DEPLOYMENT_TARGET 4.2
    setenv PATH "/Developer/Platforms/iPhoneOS.platform/Developer/usr/bin:/Developer/usr/bin:/usr/bin:/bin:/usr/sbin:/sbin"
    /Developer/Platforms/iPhoneOS.platform/Developer/usr/bin/llvm-g++-4.2 -arch armv7 -isysroot /Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS5.0.sdk -L/Users/azrael/Library/Developer/Xcode/DerivedData/wmelite-aregolaikwmsxtaipuhimuunwblh/Build/Products/Debug-iphoneos -L/Users/azrael/Desktop/asd/wmelite/xcode-ios/wmelite/../dep/bass/lib -L/Users/azrael/Desktop/asd/wmelite/xcode-ios/wmelite/../dep/boost/lib -L/Users/azrael/Desktop/asd/wmelite/xcode-ios/wmelite/../dep/FreeImage/lib -L/Users/azrael/Desktop/asd/wmelite/xcode-ios/wmelite/../dep/freetype/lib -L/Users/azrael/Desktop/asd/wmelite/xcode-ios/wmelite/../dep/SDL/lib -F/Users/azrael/Library/Developer/Xcode/DerivedData/wmelite-aregolaikwmsxtaipuhimuunwblh/Build/Products/Debug-iphoneos -filelist /Users/azrael/Library/Developer/Xcode/DerivedData/wmelite-aregolaikwmsxtaipuhimuunwblh/Build/Intermediates/wmelite.build/Debug-iphoneos/wmelite.build/Objects-normal/armv7/wmelite.LinkFileList -dead_strip -lz -miphoneos-version-min=4.2 -framework StoreKit -framework Foundation -framework UIKit -framework OpenGLES -framework QuartzCore -framework CoreAudio -framework AudioToolbox -framework CoreGraphics -lbass -lboost_filesystem -lboost_system -lfreeimage -lSDL -framework CFNetwork -lfreetype -o /Users/azrael/Library/Developer/Xcode/DerivedData/wmelite-aregolaikwmsxtaipuhimuunwblh/Build/Products/Debug-iphoneos/wmelite.app/wmelite

ld: in /Users/azrael/Desktop/asd/wmelite/xcode-ios/dep/FreeImage/lib/libfreeimage.a, file is universal but does not contain a(n) armv7 slice for architecture armv7
Command /Developer/Platforms/iPhoneOS.platform/Developer/usr/bin/llvm-g++-4.2 failed with exit code 1"

It seem to me that a lib dosn't support armv7Any ideas? :P
The macbook pro it's with Lion and the latest version of XCode. The ipad it's an ipad 2 with ios 5. I downloaded the latest source and dependencies of WME Lite.

Thanks for the help :)



2
Bug reports / SetTexture make game crash while saving
« on: May 10, 2010, 02:46:38 PM »
Hi, we are experiencing some problem in some scenes in which i change the texture of a 3D actor with SetTexture method.

If i save the game from one of these scenes the game crash near the end of the saving, crash.log report:

Quote
-----------------------------------------------------------------
---------- wme 1.9.001 crash report: 10-05-2010, 15:38 ----------
-----------------------------------------------------------------
wme_D3D9.exe caused a EXCEPTION_ACCESS_VIOLATION in module wme_D3D9.exe at 001B:0049CB62
EAX=00000001  EBX=0D2977F0  ECX=00000000  EDX=00000000  ESI=00000000
EDI=04EA9BE8  EBP=00000000  ESP=0012F508  EIP=0049CB62  FLG=00210202
CS=001B   DS=0023  SS=0023  ES=0023   FS=003B  GS=0000
Stack trace:
(null)

I tried removing many things but it seem it depend only by SetTexture, the code is like:
Code: WME Script
  1. car.SetTexture("Car_Taxi", "actors\car\Car_Black.png");

It's strange also because with the previous version of wme we experienced no problem with the same scripts, but now this crash seem to affect also all the scenes that before works.

Thanks for the help, i hope it's comprehensible :P

3
Technical forum / Scene.ScrollTo() not working
« on: October 27, 2009, 11:23:53 AM »
I have a scene with a resolution of 1500x768. The actor is at the right of the scene and i want the scene to scroll to a point on the left.
The problem is that the scene don't scroll. Scene.SkipTo(); work but ScrollTo(); no (i tried with X,Y and with an entity).

As written in the docs Scene.AutoScroll is set to true.
The script is something like that:

Code: [Select]
Game.Interactive = false;
Scene.AutoScroll = true;
Scene.ScrollTo(164, 511);
Game.Interactive = true;

The game become non interactive and wait forever for the scene scrolling :(

4
Not a bug / Scene.SkipTo() not working on vertical scrolling scene
« on: October 20, 2009, 09:09:25 AM »
In a game with a resolution of 1024x768 we have a scene in 1024x850.
Entering from another location the actor is placed vertically at the middle of the scene so, when the actor enter in the scene, the scene scroll up a bit.
With another position for the actor at the top of the scene it do the same.

I have tried "Scene.SkypTo(X, Y);" and also "Scene.SkypTo(actor);" but the scene always scroll down to the actor's position.

In horizontal scrolling scene i have no problem, it works perfectly. But in this scene it doesn't seem to want to work  :-\

5
Technical forum / Scripting iteraction with response
« on: September 27, 2009, 01:58:46 PM »
It's possible to select a response (added with "AddResponse") with script when the game is waiting for the player to select a response?

For example, i add 4 response with Game.AddResponse():

Code: WME Script
  1. Game.AddResponse(1, "Resp 1.");
  2. Game.AddResponse(2, "Resp 2");
  3. Game.AddResponse(3, "Resp 3.");
  4. Game.AddResponse(4, "Resp 4.");
  5.  
  6. var Selected = Game.GetResponse();

Now the game is waiting for a response to be choosed by the player. What i want now is to automatically choose a response if the player don't choose one in "X" minutes. It's possible?

Thanks ;)

6
Technical forum / Attached Object and looping animation
« on: June 03, 2009, 08:16:25 AM »
I have a 3D actor with an object attached to it. The problem is that if a try to play a looped animation the animation play correctly, but don't loop.
It's possible to loop it? It's set to loop in the object act3d file.

I have also tried to set the animation as idle with "IdleAnimName" attributes, but with no results.

7
Technical forum / How is the FOV calculated?
« on: May 20, 2009, 06:52:16 PM »
I mean the FOV in *.scene files.

I have a scene with FOV 30.07 but in the .scene file it's:

Code: WME Script
  1. FOV_OVERRIDE=0.524995

There is a way to calculate the "FOV_OVERRIDE" from a number like "30.07"? I need it to improve my model viewer ;)

8
Technical forum / Setting window element.Text and string tab
« on: April 08, 2009, 04:21:43 PM »
Hi,
when i try to set the Text attribute to a window using string from string tab the text appear with the string tab id, something like that: /syseng0707/My text

This is the script:

Code: WME Script
  1. if (CurrentCat == 2)
  2.                 {
  3.                 this.Text = "/syseng0707/My text";
  4.                 }
  5.  

Obviusly in string tab there is the right line:
syseng0707    My text

There is a way to make it work propely with string tab?
I tried also with a static control but with the same results  :(

9
Technical forum / Overwrite Game Methods
« on: April 04, 2009, 06:39:48 PM »
It's possible to overwrite "Game." methods?

I know it's possible to overwrite others methods (like actor methods), but now i would like to overwrite the "Game.TakeItem" method and, if yes, in which file should i put the new method?

I try something but none works  :-\

Tnx :)

10
Scripts, plugins, utilities, goodies / 2.5D models viewer
« on: March 08, 2009, 11:49:04 AM »
Sorry if my English is not perfect, i hope it's readable :P

To some team need i created a "tool" with WME used from the modelers to test 3D models. It can be used obviously to see how an object will be rendered in wme but also to test animation, attached objects, actor scale, lights, shadow, "load" custom scenes to see how the characters appear in the real scene (only a 2.5D scene) and also set the options of a particles emitter to create custom effects (you can also save the settings in a txt file).

I think it's quite easy to use (all the work is do renaming and replacing some files in some directory, except for the particle emitter obviously). We found it very useful because the modelers could test their models without learning how to use WME or without sending me the model, waiting until i make a demo and i sent it back. It fasted the work a lot (we work mainly in internet due to a bit o distance :P ).

Don't expect to be a state of the art tool :) It was developed adding pieces as we needed them and i don't put particularly attention to good scripting. So surely something could be done better. But it's works and for now, for us, is enough and i have also something different to do :P

Another problem may be some English translation, sorry ;)

For these reason i release also the source code of the viewer. So, if you find some bug, if some translations are wrong or could be better, if you want to translate it to another language or if you want to improve/add something, feel free do do it.

The only thing i ask is to maintain the original credits (add yours obviously) and to share yours mods to the comunity :)

Inside the viewer you will find a README with some basic instructions.

Viewer English version: http://www.madorange.it/viewer/Viewer_1.0.rar
Italian translation (simply overwrite existing "lang" file): http://www.madorange.it/viewer/Viewer_1.0_ITA_lang.rar
Source code: http://www.madorange.it/viewer/Viewer_1.0_source.rar


I hope somebody would find it useful :)

11
Game announcements / Face Noir
« on: October 21, 2008, 09:30:17 AM »
Hi, finally we can annunce the start of our first game: "Face Noir – The cat with the jade eyes".

I'm not so good in english so, for now, i will only tell that the game is in it's first stage of development, it will be a commercial game and leave the link to the site: http://www.facenoir.com/

Obviusly the game will be made with the fantastic Wintermute Engine :)

12
Technical forum / Problem exporting characters with Physique
« on: April 30, 2008, 04:28:02 PM »
Hi,
me and a friend, the artist, are doing some test for a possible game.
My friend have some problem exporting characters using 3D studio max 9 with Physique. After exporting in .x format the character seem to be ok but, when we try to play an animation, only the skeleton (done with biped) play it, the mesh don't move.

We have this problem only with Physique. My fried try with another modifier, skin, and all works. We also try to use some method find searching in this forum but none worked.


P.S.: Sorry for my poor english  :P

Pages: [1]

Page created in 0.2 seconds with 22 queries.