Please login or register.

Login with username, password and session length
Advanced search  

News:

For WME related articles and tutorials visit WME Resource Center.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - Amo

Pages: [1] 2 3
1
Technical forum / Again, the cyrilic question
« on: July 10, 2008, 01:27:13 PM »
Please folks, don't throw rocks at me.

First of all the situation:
We had done "SUNRISE the game" in late 2007 and turned over to another project which was running parallel but at this point we completely focused on this second project. So for now: We are off WME completely. I mean really completely. Lot of beer and more than a half year of WME abstinence killed several parts of our brains. Now we received the russian translation. Nobody here speaks russian. All the text is in one excel file. What we need now is a step by step advice for braindead people how to prepare WME for one hell of an copy and paste action. For making things even harder: We are using 1.8Beta3 as we released with the beta because we were hard at schedule limit and will be not able to switch to a newer version. We have also (to make the chaos perfect) no text stored in stringtables. Everything is stored in the scripts. Sorry for all the inconvenience, but your help is really appreciated. Thanks so much in advance folks! Missing the Wintermute times...

Amo

2
Technical forum / Need help creating a trial version
« on: October 09, 2007, 12:03:13 PM »
Hey guys and girls,

erm, has anybody an idea how to create something like a thirty day trial version with the help of WME? In our particular case we want to make our current stable version make run only for thirty days after installing.
Please do not ask why.

Thanks for upcoming help.

Regards

Amo

3
Technical forum / Starforce
« on: October 02, 2007, 01:08:35 PM »
Hi there!

I've read in this thread http://forum.dead-code.org/index.php?topic=1692.0 that starforce is supported by WME since version 1.4
How is the current status? Which version is supported? Has anybody worked with it and how will it be if the game ships on more than one disk? In our case it will be 2 DVD's (very large WME project imho).

Thanks for upcoming answers.

Cheers

Amo

4
Done / Distributing single packages?
« on: September 13, 2007, 09:57:42 PM »
Hey folks. Maybe I missed something but I couldn't find anything about it. Is there any possibility to distribute only single packages without compiling the whole game? May sound strange but image the following: You make some testing and run into a bug. Nothing special. You make a correction and than: You have to wait until the full game has been compiled. That costs a lot of time. Wouldn't it be nice if you have to wait only for the package where the changes have been made (in our case it costs around 10 minutes to compile the whole game)

Regards

Amo

5
Not a bug / Sound cracking under Vista
« on: September 12, 2007, 05:10:22 PM »
Hi Mnemonic,

on our Vista system is the sound cracking (hope it is the right word...). It means, that the sound is playing but it makes short noises while playing.

The specs are the following:

Vista Ultimate
AC97 Onboard sound (Gigabyte board)

Are there any known issues? It happens only in WME not in other progs/games. So it doesn't seem to be a driver issue.
The game has been compiled with 1.8beta3

Regards

Amo

6
Technical forum / Problems with scene change via doubleclick
« on: August 24, 2007, 06:03:48 PM »
Hi there its me again.

Following when clicking on a scene exit region with one click our actor walks there and the scene change starts. Nice, anyway, this lasts sometimes very long so it has been added that the scene cuts immediately when double clicking on the exit region. This works mostly fine but sometimes the following happens:
The fade out starts, the new scene fades in you see also the actor than a very short fadeout-fade in happens and the actor gets "beamed" to its default position set for the scene. The debugger shows that the last scene and the actual scene are the same, in short: The scene gets loaded two times. The problem is, that it happens nearly radomly which makes it nearly impossible to reproduce the problem or the reason which is behind this behaviour. Has anybody any idea or the same strange behaviour?

Thanks for upcoming answers

Amo

7
Technical forum / Turning Anim troubles with 3d actor
« on: August 23, 2007, 09:29:53 PM »
Hey folks,

I added a cute little turning animation for our actor, called it turnright and packed it in a separate X file.
Than the X file and the animation name have been added to the actors Act3d file but something is wrong.
The actor is still performing some nice little figure skating when turning and doesn't react on the animation.
(Do not wonder why I only made a turnright, it is just a starting point to test it out, left will follow).
Are there any restrictions I missed? It is a 3d actor and with classical point and click.

Regards and thanks for upcoming answers

8
Done / Anim channels which gets erased at the file end
« on: August 16, 2007, 11:10:02 AM »
I discussed that already with Mnemonic via mail but for the community I post the complete idea behind:

Erm, we play a standard talk animation. Over this talk animation we want to overlay a short anim which contains way more movement in the arms, but it is only an arm animation the rest WME shall take from the standard anim, achieved by removing all the other keys. WME plays this channel very fine till the end of the talk line and than via stopanimchannel the channel gets erased, the talk stops and the character starts to idle. This is when the channeled anim is loopable.
But imagine the channeled anim has a very hard motion something like the arm is raised to the air and than the arm is going back to a neutral pose, but the talk line ends right in the highest point of the arm. WME makes in this case a hard cut and the anim looks like cutted or created by an idiot.

Next way: A non loopable anim in the channel. In this case WME runs the channeled anim till its end, but if the talk line is longer, the whole arm anim gets freezed till the end of the talkline. If the talk line is very short, the same thing occurs as like in the loopable the anim looks cutted.
 
What we want is, that we use only non loopable anims for the channel. In our example the arms rise one time than go back and thats the end of the channeled anim and WME continues only with the standard talk anim.

So it would be cool if there is any way, that WME recognizes the end of the channeled anim and erases it after the end without giving a da** about the end of the talkline. When the talk line is longer, only the standard channel continues playing, if the talk line is shorter the actors starts to idle but the channel runs till the end of the channeled anim so the arms go back as animated and not as
cutted, then the channeled anim gets erased out of the channel.
 

9
Technical forum / How about the crash logs?
« on: August 15, 2007, 06:27:05 PM »
Hey Jan,

we had several WME crashes while scene changes today but the crash log has been updated last time at the beginning of july as we latestely used WME 1.7
Don't they work anymore since 1.8beta? Actually we are using beta2

Regards

Martin

10
Technical forum / actor.IsWalking
« on: July 10, 2007, 10:34:10 AM »
What can we do with actor.IsWalking?
The goal was to find out if the actor is walking or not.
So we used actor.IsWalking and printed it on the screen. When in main menu, the game message says "no"
thats right, but when entering the game no such game message appears, wether "yes" nor "no".
So whats the trick? Or is there anything equal which can do this? Or is it only for direct control?
"Ready" is also no option, as we use a lot of random events for the actors, such as randomidle animations.

Any help?

11
Technical forum / Reading the target coordinates
« on: July 09, 2007, 10:05:30 PM »
Hi Folks,

is there any way to get out of WME the following information:
When clicking somewhere in the scene, WME does know, if the actor needs to walk, or not.
When he needs to walk, he needs the correct target coordinates, right?
Is it possible to catch these coordinates?

12
Technical forum / Query animation channels?
« on: July 03, 2007, 03:50:30 PM »
Hi folks,

is there any posibility to query if the animation in a specific animation channel has ended, or not?

Thanks for upcoming answers

Amo

13
Technical forum / Confused about the animchannels
« on: June 28, 2007, 02:55:45 PM »
Hi there, me again.

We tried the Playanimchannel thing today and it works (*wow*). Ok, at least it works so damn good,
that the animation in channel one overrides the standard animation in channel 0 completely.
Let me explain. The actor plays a standard talk animation in channel 0. For channel 1 I created a new
Headmovement for the animation, to let the actor react on different events surrounding him.
This head anim contains the complete bipedal structure, as wme needs, but only keys for the head.
What's my mistake? I know that it can work, as it works for Trinity. Maybe some exporting mistake.

Thanks for upcoming answers

Amo

14
Technical forum / more than one x-file for each NPC
« on: June 27, 2007, 10:48:23 PM »
Hi folks,

following thing. I prefer to split my animations to different x-files because some will be changed from time to
time.

For the main actor e.g. means that, one for walk, idle and dummy, another one for all "picking things up" actions and so on.

No I tried the same for the NPC's as their animation stock is growing but damn! It doesn't work.
For example. First file contains the mesh, the walk and the idle anim, the second one some talk anims.
When it is time for WME to let that guy talk, he jumps back into the last walk frame. When setting the idle
as a talk animation, he jumps after walking to the idle anim and loops it, starts all talking, but with the idle animation. As expected, but as written above, both are in the same x-file.
Ain't it possible to use more x-files for the NPC's?

Thanks for upcoming answers

regards

Amo

15
Technical forum / A nice scene switching
« on: June 26, 2007, 10:47:33 AM »
Hi there,

after searching a while around in the forum I found a nearly similar thread from SBovis but the solution was not really clear for me and it lasts a way back time.

Most of our scenes changes are fast enough to make an loading screen unnecessary but, as you might have
expected, some not. A blank black screen ain't very nice. As it seems making an animation while loading a
scene is not really possible (at least I've read it that way, not sure if it is right).
So I could need a little walkthrough or stuff like that how to insert a nice picture, while performing the change.
If I read it wrong and an animation would be possible, no matter if smooth or not, a walkthrough would be
perfect, too.

Thanks for upcoming answers

Amo

Pages: [1] 2 3

Page created in 0.267 seconds with 21 queries.