Please login or register.

Login with username, password and session length
Advanced search  

News:

Forum rules - please read before posting, it can save you a lot of time.

Author Topic: WME connecting to Microsoft at startup?  (Read 1895 times)

0 Members and 1 Guest are viewing this topic.

Django

  • Lurker
  • *
  • Karma: 0
  • Offline Offline
  • Gender: Male
  • Posts: 11
    • View Profile
WME connecting to Microsoft at startup?
« on: March 26, 2006, 03:35:33 PM »

Hi there,

I am (obviously) new to this forum, just started wintermuting. I've been using AGAST for a while, but there were some reasons for me to change the engine, so I gave Wintermute a try and started porting parts of my game to it. So far I am quite content with this capable engine, there is just one thing that gives me a headache: Everytime I run the game from ProjectMan, it tries to connect to crl.microsoft.com. If I let my Firewall block the connection, the game's execution is delayed for a while, which can get quite annoying at times. I could live with that, but then I realised that even the final compiled project behaves this way. So my questions are:

  • What is the purpose of this (something about certificates, but what exactly)?
  • Is it really necessary, or is there a possibility that at least the final build doesn't behave like this? IMO it looks quite unappealing if my game (or any program as well) tries to contact Big Brother at startup.

Thanks in advance,
Django

p.s. I'm using Win2K, just tried it on XP a few minutes ago, where the connection request doesn't occur.  ???

Logged

Jerrot

  • Global Moderator
  • Addicted to WME forum
  • *
  • Karma: 0
  • Offline Offline
  • Gender: Male
  • Posts: 690
    • View Profile
Re: WME connecting to Microsoft at startup?
« Reply #1 on: March 26, 2006, 03:51:11 PM »

Welcome Django,

well yes, this behaviour is known, though its not the engine itself that connects to "Big Bro'", but some WHQL certified videocard drivers do that.

As far as I know (but that information is about 6 months old), Mnemonic found no real workaround for that yet, but if you allow that connection once, it shouldn't connect afterwards anymore.

There also is some checkbox in the DirectX settings (dxdiag) about it. Actually it *should* stop this behaviour when this checkbox is unchecked (and therefore it'd be up to your users and should not only be WME specific) but it seems that this doesn't always work for some reason.  ???

I hope my information is not too outdated, maybe someone want to correct me. ;)

Jerrot.
Logged
Mooh!

Mnemonic

  • WME developer
  • Administrator
  • Addicted to WME forum
  • *
  • Karma: 41
  • Offline Offline
  • Gender: Male
  • Posts: 5679
    • View Profile
    • Dead:Code Site
Re: WME connecting to Microsoft at startup?
« Reply #2 on: March 26, 2006, 04:22:39 PM »

Also, this issue seems to be DirectX 7 related. The newer DirectX versions provide means of disabling digital signature check programatically (that's what WME does for DX8).
So, in theory, if your game is set to require 3D acceleration (hence it doesn't query DirectX 7 devices at startup), it shouldn't connect to microsoft. This is yet to be confirmed, though.
« Last Edit: March 26, 2006, 04:26:03 PM by Mnemonic »
Logged
Yes, I do have a twitter account
Please don't send me technical questions in private messages, use the forum. ::wave

Django

  • Lurker
  • *
  • Karma: 0
  • Offline Offline
  • Gender: Male
  • Posts: 11
    • View Profile
Re: WME connecting to Microsoft at startup?
« Reply #3 on: March 26, 2006, 07:07:08 PM »

Ok, I see.
I've set the option "Require 3D accel." to "Yes" - problem solved for the time being. Though it might sound strange if the game's label reads "old school 2D graphic adventure game - 3D accelerated video card required". But who cares, nowadays...

Thanks for the information, Jerrot and Mnemonic!

Django
Logged

Mnemonic

  • WME developer
  • Administrator
  • Addicted to WME forum
  • *
  • Karma: 41
  • Offline Offline
  • Gender: Male
  • Posts: 5679
    • View Profile
    • Dead:Code Site
Re: WME connecting to Microsoft at startup?
« Reply #4 on: March 26, 2006, 09:44:44 PM »

Well, it's just a workaround.. Unfortunately there doesn't seem to be any feasible way of disabling this Microsoft's "feature" in DirectX 7.
Logged
Yes, I do have a twitter account
Please don't send me technical questions in private messages, use the forum. ::wave
 

Page created in 0.52 seconds with 22 queries.