Please login or register.

Login with username, password and session length
Advanced search  

News:

Forum rules - please read before posting, it can save you a lot of time.

Author Topic: WME 1.2 Build 044  (Read 3480 times)

0 Members and 1 Guest are viewing this topic.

Mnemonic

  • WME developer
  • Administrator
  • Addicted to WME forum
  • *
  • Karma: 41
  • Offline Offline
  • Gender: Male
  • Posts: 5679
    • View Profile
    • Dead:Code Site
WME 1.2 Build 044
« on: July 07, 2004, 06:46:22 PM »

Hiya everyone,

here's a new WME version. It's mainly a maintenance release fixing several bugs and problems of the previous major build, but there are some nice new features too ;)

WME update: http://www.dead-code.org/download/wme_build_044.exe (1.9MB)
Updated documentation: http://www.dead-code.org/download/wme.chm (2.8MB)


(Note 1: you must have the WME DevKit installed prior to installing this patch)
(Note 2: saved games are incompatible with previous releases)



Version 1.2, build 044 (July 7, 2004)

  • loading/saving screen - can be defined in ProjectMan or using the Game.SetLoadingScreen() and Game.SetSavingScreen() methods
  • new Game.ScreenshotEx() method which allows to save scaled screenshot with a fixed filename
  • new const keyword for defining constant variables - similar to global, but constant variables are not affected by resetting the game
  • new Item.AmountString attribute which allows you to display any text label beside the inventory item
  • added a "none" option when setting the walk-to direction in SceneEdit
  • FIX: mouse pointer no longer goes off-screen when running the game in a dual-monitor environment
  • FIX: occasional crash when changing scene after loading a saved game
  • FIX: fixed several mistakes in the documentation
  • FIX: WME no longer checks for removable drives at startup which caused problems with network-mapped volumes
Logged
Yes, I do have a twitter account
Please don't send me technical questions in private messages, use the forum. ::wave

Nihil

  • Supporter
  • Addicted to WME forum
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 528
  • Fear me! I'm evil!
    • View Profile
    • Order of Dagon
Re: WME 1.2 Build 044
« Reply #1 on: July 08, 2004, 07:27:00 PM »

I have just tested the new build, and the mouse cursor leaves the main monitor on my system (Geforce 5600 with 2 Monitors connected using nView-driver - not a dual-graphics card system), but this should be no problem at all - I just tested some other games, and it happens in all of them, I only never noticed it before because I usually switch off the second monitor while playing :-)

But therefore another problem arose: when I run the game from Projectman the mouse cursor becomes invisible - this did not happen in the previous build.

EDIT: I just tested it again:  it shows me two devices, one opens the game on the second monitor -> there the cursor dissapears, and the other device opens it on the main monitor, -> everythings fine there

So it think it's not a real problem at all.
« Last Edit: July 08, 2004, 07:38:38 PM by Nihil »
Logged

Mnemonic

  • WME developer
  • Administrator
  • Addicted to WME forum
  • *
  • Karma: 41
  • Offline Offline
  • Gender: Male
  • Posts: 5679
    • View Profile
    • Dead:Code Site
Re: WME 1.2 Build 044
« Reply #2 on: July 08, 2004, 08:50:14 PM »

Thank you for the info. I changed the code a little anyway. Could you please test this new build?

http://dead-code.org/download/wme_latest.zip

It should work on either monitor now, hopefully. Thanks.
Logged
Yes, I do have a twitter account
Please don't send me technical questions in private messages, use the forum. ::wave

Nihil

  • Supporter
  • Addicted to WME forum
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 528
  • Fear me! I'm evil!
    • View Profile
    • Order of Dagon
Re: WME 1.2 Build 044
« Reply #3 on: July 08, 2004, 09:52:39 PM »

Now it gets really strange  ;D

The device for the main monitor still works without problems, but the one for the second shows a very strange behaviour: It opens the game on the second monitor, but the cursor is still on the first, and it gets stuck into some invisible borders, I can only move it in the upper left quarter of the monitor - now way out  ;) (This happens when I start the game from Project Manager)

In the compiled version the cursor still leaves the main monitor, but only a little bit, maybe ~100 pixels or so?

odnorf

  • w00t?
  • Global Moderator
  • Addicted to WME forum
  • *
  • Karma: 7
  • Offline Offline
  • Gender: Male
  • Posts: 1454
  • Lamp dog!
    • View Profile
Re: WME 1.2 Build 044
« Reply #4 on: July 10, 2004, 08:16:47 PM »

... and that's the last time I'm going to mention that the greek translation is ready  ;) it always is afterall
Logged
fl*p
 

Page created in 0.193 seconds with 23 queries.