Please login or register.

Login with username, password and session length
Advanced search  

News:

For WME related articles and tutorials visit WME Resource Center.

Author Topic: Issues with Packages and Patch  (Read 1049 times)

0 Members and 1 Guest are viewing this topic.

valter.home

  • Supporter
  • Occasional poster
  • *
  • Karma: 1
  • Offline Offline
  • Gender: Male
  • Posts: 55
    • View Profile
Issues with Packages and Patch
« on: January 13, 2016, 08:42:16 PM »

Hello, I'm seeing for the first time the operations to be done to create the various packages but I have a difficulty.
For example, if I move my folders "sounds" and "music" in a folder "audio" and I do "promote to package" everything works fine.
But if I try to create files to "patch" the game the engine does not update to the new files.
These are the operations I perform:
I create a folder "patch" in the top level structure
in project managers I do "promote to package"
I change the priority to 1 or 10 or more
then I recreate in the folder "patch" the same path of the folder "data" such scenes - myroom - src - scene_init.script
Obviously I copy the original content in this script and I change one little thing, for example I do speak the actor
I save and then I compile everything or just the folder "patch".
No results, whether I start the game from wme whether I start the exe file.
I use version 1.9.001

Any suggestions?

Thank you
Logged

valter.home

  • Supporter
  • Occasional poster
  • *
  • Karma: 1
  • Offline Offline
  • Gender: Male
  • Posts: 55
    • View Profile
Re: Issues with Packages and Patch
« Reply #1 on: January 14, 2016, 10:05:05 AM »

I don't understand, I'm losing a lot of time to seek a solution.
To avoid any problems of code I got the demo bookgame online, added some music and then I tried to simulate updates of some files.
I also tried to download the beta version 1.10.1 but it does not change anything, it seems that the engine does not see the package "patch".
The package "audio" works correctly.
Someone would know tell me where I'm wrong?
I don't know if it's helpful, but I work on Seven 64bit. However, I have also tried on a XP 32bit.
None of you had similar problems?

Thank you



Logged

anarchist

  • Regular poster
  • ***
  • Karma: 5
  • Offline Offline
  • Gender: Male
  • Posts: 212
    • View Profile
Re: Issues with Packages and Patch
« Reply #2 on: January 14, 2016, 09:31:45 PM »

The problem is that you haven't copied the exact folder structure.

The original has path scenes/Dream/scr

The patch one has path scenes/Dream/src

A very annoying little bug that simply needed fresh eyes to look at it.
Logged

valter.home

  • Supporter
  • Occasional poster
  • *
  • Karma: 1
  • Offline Offline
  • Gender: Male
  • Posts: 55
    • View Profile
Re: Issues with Packages and Patch
« Reply #3 on: January 15, 2016, 09:17:41 AM »

A very annoying little bug that simply needed fresh eyes to look at it.

Damn!
This is because in my mind src = SouRCe instead scr = SCRipt !!!
I am sure that without your help, would go a long time before I realized this error.
Thank you very much!

V
Logged
 

Page created in 0.169 seconds with 22 queries.